[cinder] Cannot upload volume to image

Bug #1523457 reported by Sergey Arkhipov
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mirantis OpenStack
Fix Released
High
Yuriy Nesenenko
7.0.x
In Progress
High
Yuriy Nesenenko

Bug Description

Cannot upload volume to image if volume source has description.

Steps to reproduce:
    * Upload image to Glance
    * Set image description to some non empty string (i've used "nfvpilot / nfvpilot")
    * Create volume from image
    * Try to upload volume as image back to Glance

In logs:
2015-12-07T11:24:16.452104+00:00 info: HTTP exception thrown: Unable to set 'properties' to '{u'description': u'nfvpilot / nfvpilot'}'. Reason: {u'description': u'nfvpilot / nfvpilot'} is not of type u'string'

Failed validating u'type' in schema[u'additionalProperties']:
    {u'type': u'string'}

On instance['properties']:
    {u'description': u'nfvpilot / nfvpilot'}

Please check attached logs for "BuggyImage".

VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  openstack_version: "2015.1.0-8.0"
  api: "1.0"
  build_number: "199"
  build_id: "199"
  fuel-nailgun_sha: "a65871a955dd0886b9c2e18f7a24381f10753136"
  python-fuelclient_sha: "3e7738fd3fb18a2d5f53b1ecc9706dc53b65a511"
  fuel-agent_sha: "88c993eab990ddb7b5f038490295f52c602aa58b"
  fuel-nailgun-agent_sha: "b56f832abc18aee9a8c603fd6cc2055c5f4287bc"
  astute_sha: "c8400f51b0b92254da206de55ef89d17fdf35393"
  fuel-library_sha: "33c0fa3aada734dc9e6f315197ce0e4a16f5987c"
  fuel-ostf_sha: "11afd5743a12b1006317d3ca7000d1ede77bdae2"
  fuel-createmirror_sha: "994fed9b1ed889718b61a59733275c08c2dd4c64"
  fuelmenu_sha: "d12061b1aee82f81b3d074de74ea27a6e962a686"
  shotgun_sha: "c377d163519f6d10b69a654019d6086ba5f14edc"
  network-checker_sha: "2c62cd52655ea6456ff6294fd63f18d6ea54fe38"
  fuel-upgrade_sha: "1e894e26d4e1423a9b0d66abd6a79505f4175ff6"
  fuelmain_sha: "22fe551f5525d11a1854fd87dbc8c77fae8fec08"

Revision history for this message
Sergey Arkhipov (sarkhipov) wrote :
Changed in mos:
assignee: nobody → MOS Cinder (mos-cinder)
milestone: none → 8.0
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Yuriy Nesenenko (ynesenenko) wrote :

What do you mean by 'Set image description to some non empty string'? An image doesn't have description property.

Changed in mos:
status: Confirmed → Incomplete
assignee: MOS Cinder (mos-cinder) → Sergey Arkhipov (sarkhipov)
Revision history for this message
Sergey Arkhipov (sarkhipov) wrote :

Yuriy, sorry of being unclear. All meant operations were done using Horizon, please check screenshot. You may get this model window in Horizon by proceeding to 'System' -> 'Images' -> 'Edit image'

Changed in mos:
assignee: Sergey Arkhipov (sarkhipov) → Yuriy Nesenenko (ynesenenko)
status: Incomplete → Confirmed
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Fix proposed to openstack/cinder (openstack-ci/fuel-8.0/liberty)

Fix proposed to branch: openstack-ci/fuel-8.0/liberty
Change author: Tomoki Sekiyama <email address hidden>
Review: https://review.fuel-infra.org/14842

Changed in mos:
status: Confirmed → In Progress
Revision history for this message
Yuriy Nesenenko (ynesenenko) wrote :
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Change abandoned on openstack/cinder (openstack-ci/fuel-8.0/liberty)

Change abandoned by Yuriy Nesenenko <email address hidden> on branch: openstack-ci/fuel-8.0/liberty
Review: https://review.fuel-infra.org/14842

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Change restored on openstack/cinder (openstack-ci/fuel-8.0/liberty)

Change restored by Yuriy Nesenenko <email address hidden> on branch: openstack-ci/fuel-8.0/liberty
Review: https://review.fuel-infra.org/14842

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Fix merged to openstack/cinder (openstack-ci/fuel-8.0/liberty)

Reviewed: https://review.fuel-infra.org/14842
Submitter: Pkgs Jenkins <email address hidden>
Branch: openstack-ci/fuel-8.0/liberty

Commit: be714801f056952f89ced4b44fb125d1dc3f88ab
Author: Tomoki Sekiyama <email address hidden>
Date: Thu Dec 24 16:14:06 2015

Fix volume upload failure with glance_api_version=2

When the volume has additional image properties, upload-to-image
using glance API version 2 will fail with the following error.

  Failed validation u'type' in schema[u'additionalProperties']:
      {u'type': u'string'}

This is due to non core properties passed as a dict to the key
'properties'. It is valid in Image API v1, but the additional
properties must be passed just like core properties in v2.

Closes-Bug: #1523457
Change-Id: I69b6ddd8823916bdd4e3cfd82ebb9b3546915706

Changed in mos:
status: In Progress → Fix Committed
Revision history for this message
Forrest Flagg (fostro-flagg) wrote :

This also seems to be an issue in 7.0. Is there any work to back port the fix?

tags: added: area-cinder
tags: added: on-verification
Revision history for this message
Evgeny Sikachev (esikachev) wrote :

verified on 478 iso

Changed in mos:
status: Fix Committed → Fix Released
tags: removed: on-verification
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Fix proposed to openstack/cinder (9.0/mitaka)

Fix proposed to branch: 9.0/mitaka
Change author: Tomoki Sekiyama <email address hidden>
Review: https://review.fuel-infra.org/21037

Revision history for this message
Alexey Stupnikov (astupnikov) wrote :
tags: added: customer-found
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Change abandoned on openstack/cinder (9.0/mitaka)

Change abandoned by Alexander Evseev <email address hidden> on branch: 9.0/mitaka
Review: https://review.fuel-infra.org/21037

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers