Can't ping SR-IOV VM when 2 SR_IOV enable on different numa nodes

Bug #1660694 reported by Kristina Berezovskaia
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mirantis OpenStack
In Progress
High
Alexander Adamov

Bug Description

During verification bug https://bugs.launchpad.net/mos/+bug/1643081 I see the situation, when vms are active, but not available

Steps:
1) Enable sr-iov on 2 interfaces on different numas
2) Deploy env
3) Creat direct port and boot vm
NET_ID_1=$(neutron net-list | grep net_EW_1 | awk '{print$2}')

neutron port-create $NET_ID_1 --binding:vnic-type direct --device_owner nova-compute --name sriov_1
port_id = $(neutron port-list | grep ‘sriov_1' | awk '{print$2}')
nova boot vm1 --flavor m1.small --image ubuntu_image --availability-zone nova:$NODE_1 --nic port-id=$port_id --key-nae vm_key

4)ping vm rom dhcp-interface
Expected results:
Vm is in active state and is pinging
Actual result:
vm is in Active state but isn't pinging

Env:
snap 822? 1 compute with sr-iovs on 1 nume, 1 compute with 2 sr-iovs on different numas

Changed in mos:
milestone: none → 9.2-mu-1
importance: Undecided → Medium
Changed in mos:
importance: Medium → High
assignee: nobody → MOS Neutron (mos-neutron)
status: New → Confirmed
tags: added: area-neutron neutron
Revision history for this message
Kristina Berezovskaia (kkuznetsova) wrote :
Revision history for this message
Kristina Berezovskaia (kkuznetsova) wrote :

We don't have proper driver i40evf in our image. The problem is because of that

Changed in mos:
status: Confirmed → Invalid
Revision history for this message
Timur Nurlygayanov (tnurlygayanov) wrote :

Hi Mikhail, could you please take a look?

Changed in mos:
status: Invalid → Incomplete
assignee: MOS Neutron (mos-neutron) → Mikhail Chernik (mchernik)
Revision history for this message
Mikhail Chernik (mchernik) wrote :

Hi Timur,

Kristina is right - she used ubuntu-trusty cloud image for testing, which lacks SR-IOV driver for XL710-based cards (i40evf). As far as I know she added the driver to the image and now test passed.

Revision history for this message
Kristina Berezovskaia (kkuznetsova) wrote :

If customers have such problems, it is necessary to build image with this driver or make it using trusty image (create vm with trusty image, download and install i40evf driver, make snap from it and boot vm from this snap)

Changed in mos:
assignee: Mikhail Chernik (mchernik) → Fuel Documentation Team (fuel-docs)
status: Incomplete → Confirmed
Revision history for this message
Mikhail Chernik (mchernik) wrote :

The driver can be added by installing linux-image-extra packet: sudo apt-get install linux-image-extra-$(uname -r)

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix proposed to mos/mos-docs (master)

Related fix proposed to branch: master
Change author: Mariia Zlatkova <email address hidden>
Review: https://review.fuel-infra.org/30341

Changed in mos:
status: Confirmed → In Progress
tags: added: release-notes
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix merged to mos/mos-docs (master)

Reviewed: https://review.fuel-infra.org/30341
Submitter: Olena Logvinova <email address hidden>
Branch: master

Commit: 5d6fc4295c6c6498d177f383086b43ffe71a9551
Author: Mariia Zlatkova <email address hidden>
Date: Wed Feb 1 16:07:12 2017

[RN-9.2] Neutron known issue

Change-Id: I5297d6ffa71177176904c2bcdde695fab01394db
Related-Bug: #1660694

tags: added: release-notes-done
removed: release-notes
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix proposed to mos/mos-docs (stable/9.2)

Related fix proposed to branch: stable/9.2
Change author: Mariia Zlatkova <email address hidden>
Review: https://review.fuel-infra.org/30364

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix merged to mos/mos-docs (stable/9.2)

Reviewed: https://review.fuel-infra.org/30364
Submitter: Mariia Zlatkova <email address hidden>
Branch: stable/9.2

Commit: 5649494086e53e4ab12ba97a7da48ba4a1ecefb9
Author: Mariia Zlatkova <email address hidden>
Date: Thu Feb 2 10:40:27 2017

[RN-9.2] Neutron known issue

Change-Id: I5297d6ffa71177176904c2bcdde695fab01394db
Related-Bug: #1660694
(cherry picked from commit 5d6fc4295c6c6498d177f383086b43ffe71a9551)

Revision history for this message
Atsuko Ito (yottatsa) wrote :

For verification purposes, we should properly maintain test image (e.g. we'd rebuilt Cirros for 9.0 for SR-IOV verification purposes).

For production usage, it's not a known issue, but it's the way how things works. It should be on User guide.

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix proposed to mos/mos-docs (master)

Related fix proposed to branch: master
Change author: Mariia Zlatkova <email address hidden>
Review: https://review.fuel-infra.org/30461

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix merged to mos/mos-docs (master)

Reviewed: https://review.fuel-infra.org/30461
Submitter: Olena Logvinova <email address hidden>
Branch: master

Commit: 68cc503d69d5617d4312c2f6ab1095eb5780a412
Author: Mariia Zlatkova <email address hidden>
Date: Fri Feb 3 13:48:37 2017

[Rn-9.2] Remove a RN

* Removes the release note as it's not a bug.
  Will add the required content to the NFV solution guide.
* Fixes checkniceness

Related-Bug: #1660694

Change-Id: I48878f6ca4124c1be141d931057d60c7224b59b4

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix proposed to mos/mos-docs (stable/9.2)

Related fix proposed to branch: stable/9.2
Change author: Mariia Zlatkova <email address hidden>
Review: https://review.fuel-infra.org/30465

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix merged to mos/mos-docs (stable/9.2)

Reviewed: https://review.fuel-infra.org/30465
Submitter: Olena Logvinova <email address hidden>
Branch: stable/9.2

Commit: 0a3c3497e4f34b4364fa06b23367ee10cffb4b2b
Author: Mariia Zlatkova <email address hidden>
Date: Fri Feb 3 15:01:03 2017

[Rn-9.2] Remove a RN

* Removes the release note as it's not a bug.
  Will add the required content to the NFV solution guide.
* Fixes checkniceness

Related-Bug: #1660694

Change-Id: I48878f6ca4124c1be141d931057d60c7224b59b4
(cherry picked from commit 68cc503d69d5617d4312c2f6ab1095eb5780a412)

Changed in mos:
assignee: Fuel Documentation Team (fuel-docs) → Alexander Adamov (aadamov)
Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Related fix proposed to mos/mos-docs (master)

Related fix proposed to branch: master
Change author: Alexander Adamov <email address hidden>
Review: https://review.fuel-infra.org/30467

Revision history for this message
Fuel Devops McRobotson (fuel-devops-robot) wrote : Change abandoned on mos/mos-docs (master)

Change abandoned by Alexander Adamov <email address hidden> on branch: master
Review: https://review.fuel-infra.org/30467
Reason: Moving to Fuel User Guide

Revision history for this message
Denis Meltsaykin (dmeltsaykin) wrote :

Moving from 9.2-mu-1 since Fuel User Guide is not part of maintenance updates and doesn't follow the timeframe of a MU.

Changed in mos:
milestone: 9.2-mu-1 → 9.x-updates
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers