fails to connect to VM that is created on more than 1 NUMA node

Bug #1591087 reported by Sergii on 2016-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mirantis OpenStack
Status tracked in 10.0.x
10.0.x
High
Sergey Matov

Bug Description

Detailed bug description:
When I try to launch VM on more than 1 NUMA node using hw:numa_nodes=2 on flavor, with DPDK enabled - there are no connection via SSH or Ping.

Environment: MOS 9.0 ISO 459, hardware lab
1 controller + 1 compute with DPDK (In our case node-1.domain.tld) + 1 compute.

Steps to reproduce:
Run this script on freshly deployed environment. Just replace value for compute_node_with_feature.
http://paste.openstack.org/show/510446/

Expected result:
Instance is available via SSH, ping.

Actual result:
Instance is not available via SSH, ping.

Additional information:
On compute with feature

ovs-vsctl get Open_vSwitch . other_config:pmd-cpu-mask=9c2709827 it is ([0, 1, 2, 5, 11, 12, 15, 20, 21, 22, 25, 30, 31, 32, 35]) cpu's

vcpu_pin_set from nova.conf - 6,26,7,27,8,28,9,29,16,36,17,37,18,38,19,39,3,23,4,24,13,33

node 0 cpus: 0 1 2 3 4 20 21 22 23 24
node 1 cpus: 5 6 7 8 9 25 26 27 28 29
node 2 cpus: 10 11 12 13 14 30 31 32 33 34
node 3 cpus: 15 16 17 18 19 35 36 37 38 39

Diagnostic snapshot - http://mos-scale-share.mirantis.com/fuel-snapshot-2016-06-10_08-23-56.tar.gz

Sergii (sgudz) on 2016-06-10
affects: fuel → mos
Changed in mos:
milestone: none → 9.0
tags: added: feature-dpdk
Sergey Matov (smatov) wrote :

Confirmed on 9.0 release.
This case is quite narrow. Additional information should be added to release notes.
Main option is to step on 16.04 packages.
So it won't be fixed in 9.0 since DPDK consider to be experimental.

Changed in mos:
assignee: nobody → Sergey Matov (smatov)
status: New → Confirmed
Changed in mos:
importance: Undecided → High
status: Confirmed → Won't Fix
assignee: Sergey Matov (smatov) → Fuel Documentation Team (fuel-docs)
status: Won't Fix → Confirmed
tags: added: area-docs
tags: added: release-notes
tags: added: release-notes-done
removed: release-notes
Changed in mos:
status: Confirmed → Fix Committed
assignee: Fuel Documentation Team (fuel-docs) → Maria Zlatkova (mzlatkova)
Nastya Urlapova (aurlapova) wrote :

Moved to "Fix released" regarding Dima's comment.

Changed in mos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers