[Ceilometer] Polling interval behaviour has been changed since Liberty

Bug #1575251 reported by Nadya Privalova on 2016-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mirantis OpenStack
Status tracked in 10.0.x
10.0.x
Critical
Ilya Tyaptin
8.0.x
Critical
Igor Degtiarov

Bug Description

This bug is for tracking downstream activities for fixing https://bugs.launchpad.net/ceilometer/+bug/1570967 .

The main idea for fix is to implement transformer-based metrics on compute nodes instead of do transformation on notification agents. This will allow us to support the most popular use-cases in Mitaka.

Changed in mos:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Ilya Tyaptin (ityaptin)
milestone: none → 9.0
tags: added: ceilometer

(This check performed automatically)
Please, make sure that bug description contains the following sections filled in with the appropriate data related to the bug you are describing:

actual result

version

expected result

steps to reproduce

For more detailed information on the contents of each of the listed sections see https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Here_is_how_you_file_a_bug

tags: added: need-info
Roman Podoliaka (rpodolyaka) wrote :

Why is this critical? What's the impact?

tags: added: area-ceilometer
removed: ceilometer
Ilya Tyaptin (ityaptin) wrote :

This bug is already in progress: https://review.fuel-infra.org/#/c/20082/

Reviewed: https://review.fuel-infra.org/20082
Submitter: Pkgs Jenkins <email address hidden>
Branch: 9.0/mitaka

Commit: 415ff58c53a7fdb8db6c41207b41fade2915abd3
Author: Ilya Tyaptin <email address hidden>
Date: Fri May 6 16:17:50 2016

CPU and rate pollsters in the compute agent

In this CR rate and cpu pollsters for the libvirt hypervisor
is implemented.

This stuff is required for the support cpu_util, disk.*.rate
and network.*.rate pollsters storing without any trasnfomers
work. We need this supporting because coordination of
a notification agent (which makes trasnformations) doesn't
work good and enough for the performant and consistent
sample transformations.

Change-Id: Ia3d3f466944f5b4e99f84a1d9071e12462f9822f
Closes-bug: #1575251

Roman Podoliaka (rpodolyaka) wrote :

^ fixes merged.

Changed in mos:
status: Confirmed → Fix Committed
Artem Minasyan (aminasyan) wrote :
Changed in mos:
status: Fix Committed → Fix Released
Changed in mos:
status: Fix Released → Fix Committed
Marcin Iwinski (iwi) wrote :

When can we expect this fix to be backported to MOS8?

Fix proposed to branch: openstack-ci/fuel-8.0/liberty
Change author: Ilya Tyaptin <email address hidden>
Review: https://review.fuel-infra.org/20972

Igor Degtiarov (idegtiarov) wrote :

Hi Marcin

It is already backported to MOS8.
Now patch is tested and we hope that it will be added in next update release.

Igor Degtiarov (idegtiarov) wrote :

MOS8.0 patch is in progress https://review.fuel-infra.org/#/c/20972/

Reviewed: https://review.fuel-infra.org/20972
Submitter: Pkgs Jenkins <email address hidden>
Branch: openstack-ci/fuel-8.0/liberty

Commit: a497fae8a46d9a105e4c650a89fe62815c4f4393
Author: Ilya Tyaptin <email address hidden>
Date: Fri May 20 09:22:17 2016

CPU and rate pollsters in the compute agent

In this CR rate and cpu pollsters for the libvirt hypervisor
is implemented.

This stuff is required for the support cpu_util, disk.*.rate
and network.*.rate pollsters storing without any trasnfomers
work. We need this supporting because coordination of
a notification agent (which makes trasnformations) doesn't
work good and enough for the performant and consistent
sample transformations.

Change-Id: Ia3d3f466944f5b4e99f84a1d9071e12462f9822f
Closes-bug: #1575251
(cherry-picked from downstream Ia3d3f466944f5b4e99f84a1d9071e12462f9822f)

Changed in mos:
status: Fix Committed → Fix Released
Igor Degtiarov (idegtiarov) wrote :

Steps to reproduce:
Deploy lab with several notification agents.
Add transformer-based metric in pipeline.yaml for example cpu_util:
---
    - name: cpu_sink
      transformers:
          - name: "rate_of_change"
            parameters:
                target:
                    name: "cpu_util"
                    unit: "%"
                    type: "gauge"
                    scale: "100.0 / (10**9 * (resource_metadata.cpu_number or 1))"
      publishers:
          - notifier://

Expected result: receive cpu_util metric every polling cycle for each booted vm
Actual result: cpu_util metrics are received but less often than expected.

Dmitry (dtsapikov) wrote :

Verified on 8.0+mu2

tags: added: on-verification
tags: removed: on-verification
Nadya Privalova (nprivalova) wrote :

I have added '10.0-reviewed' not to forget to change the wrong behaviour in Newton-based product. It is unlikely to fix it in upstream because this bug is architecture related, i.e. we have to do a lot of things to fix that. Now, it doesn't fit the team goal.

tags: added: 10.0-reviewed
Ilya Tyaptin (ityaptin) wrote :

Bug fix has been merged to 10.0 branch: https://review.fuel-infra.org/#/c/30658/

Fix proposed to branch: mcp/newton
Change author: Ilya Tyaptin <email address hidden>
Review: https://review.fuel-infra.org/33404

Fix proposed to branch: 11.0/ocata
Change author: Ilya Tyaptin <email address hidden>
Review: https://review.fuel-infra.org/33823

Fix proposed to branch: mcp/ocata
Change author: Ilya Tyaptin <email address hidden>
Review: https://review.fuel-infra.org/34524

Change abandoned by Ilya Tyaptin <email address hidden> on branch: mcp/newton
Review: https://review.fuel-infra.org/33404

Change abandoned by Ilya Tyaptin <email address hidden> on branch: mcp/ocata
Review: https://review.fuel-infra.org/34524

Change restored by Ilya Tyaptin <email address hidden> on branch: mcp/ocata
Review: https://review.fuel-infra.org/34524

Change abandoned by Ilya Tyaptin <email address hidden> on branch: mcp/ocata
Review: https://review.fuel-infra.org/34524

Change abandoned by Roman Podoliaka <email address hidden> on branch: 11.0/ocata
Review: https://review.fuel-infra.org/33823
Reason: we don't use 11.0/ocata anymore - mcp/ocata is the correct branch name

Change restored by Ildar Svetlov <email address hidden> on branch: mcp/ocata
Review: https://review.fuel-infra.org/34524

Change abandoned by Ildar Svetlov <email address hidden> on branch: mcp/ocata
Review: https://review.fuel-infra.org/34524

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers