Create libqb >= 0.17.0 RPM package

Bug #1381062 reported by Sergii Golovatiuk on 2014-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mirantis OpenStack
High
Aleksander Mogylchenko

Bug Description

Due to https://bugs.launchpad.net/ubuntu/+source/libqb/+bug/1341496 bug, we have issue with corosync 2.3.3. We need libqb 0.17.1 for Centos as it hits the performance making impossible to use corosync 2.3.3

Changed in mos:
importance: Undecided → High
assignee: nobody → Roman Vyalov (r0mikiam)
milestone: none → 6.0
Roman Vyalov (r0mikiam) on 2014-10-14
Changed in mos:
assignee: Roman Vyalov (r0mikiam) → MOS Linux (mos-linux)
status: New → Confirmed
Changed in mos:
assignee: MOS Linux (mos-linux) → Aleksander Mogylchenko (amogylchenko)
summary: - Create libqb 0.17.1 package
+ Create libqb >= 0.17.0 package
OSCI Robot (oscirobot) wrote :

Package libqb has been built from changeset: http://gerrit.mirantis.com/30077
RPM Repository URL: http:///osci-obs.vm.mirantis.net:82/centos-fuel-master-30077/centos

OSCI Robot (oscirobot) wrote :

Package libqb has been built from changeset: http://gerrit.mirantis.com/30076
DEB Repository URL: http:///osci-obs.vm.mirantis.net:82/ubuntu-fuel-master/ubuntu

OSCI Robot (oscirobot) wrote :

Package libqb has been built from changeset: http://gerrit.mirantis.com/30077
RPM Repository URL: http:///osci-obs.vm.mirantis.net:82/centos-fuel-master/centos

tags: added: mos-linux
OSCI Robot (oscirobot) wrote :
OSCI Robot (oscirobot) wrote :
OSCI Robot (oscirobot) wrote :

Those packages need intensive testing before merging.

Changed in mos:
assignee: Aleksander Mogylchenko (amogylchenko) → Sergii Golovatiuk (sgolovatiuk)
Changed in mos:
milestone: 6.0 → 6.1
Bogdan Dobrelya (bogdando) wrote :

@Aleksandr, what is the status of this bug?

Changed in mos:
status: Confirmed → Incomplete
assignee: Sergii Golovatiuk (sgolovatiuk) → Aleksander Mogylchenko (amogylchenko)
OSCI Robot (oscirobot) wrote :

DEB package libqb has been built for project packages/precise/libqb
Package version == , package release ==

Changeset: https://review.fuel-infra.org/1463
project: packages/precise/libqb
branch: 6.1
author: Aleksandr Mogylchenko
committer: Aleksandr Mogylchenko
subject: LP #1381062. Create libqb >= 0.17.0 package
status: patchset-created

Files placed on repository:
libqb-dev_0.17.0-2_amd64.deb
libqb0_0.17.0-2_amd64.deb

NOTE: Changeset is not merged, created temporary package repository.
DEB repository URL: /ubuntu-fuel-6.1-stable-1463/ubuntu

no longer affects: mos/6.0.x
Changed in mos:
status: Incomplete → Confirmed
milestone: 6.0.1 → 6.1
no longer affects: mos/6.1.x
Changed in mos:
assignee: Aleksander Mogylchenko (amogylchenko) → Sergii Golovatiuk (sgolovatiuk)
Bogdan Dobrelya (bogdando) wrote :

We still do want it for Centos 6.5 as it would be supported by 6.1 release. Please provide the RPM packages

description: updated
summary: - Create libqb >= 0.17.0 package
+ Create libqb >= 0.17.0 RPM package
Changed in mos:
assignee: Sergii Golovatiuk (sgolovatiuk) → Fuel OSCI Team (fuel-osci)
Changed in mos:
assignee: Fuel OSCI Team (fuel-osci) → Bartlomiej Piotrowski (bpiotrowski)
OSCI Robot (oscirobot) wrote :

RPM package libqb has been built for project packages/centos6/libqb
Package version == 0.17.0, package release == 1

Changeset: https://review.fuel-infra.org/2071
project: packages/centos6/libqb
branch: 6.1
author: Dmitry Burmistrov
committer: Dmitry Burmistrov
subject: LP #1381062. Create libqb >= 0.17.0 package
status: patchset-created

Files placed on repository:
libqb-0.17.0-1.mira1.x86_64.rpm
libqb-debuginfo-0.17.0-1.mira1.x86_64.rpm
libqb-devel-0.17.0-1.mira1.x86_64.rpm

NOTE: Changeset is not merged, created temporary package repository.
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.1-stable-2071/centos

OSCI Robot (oscirobot) wrote :

RPM package libqb has been built for project packages/centos6/libqb
Package version == 0.17.0, package release == 1

Changeset: https://review.fuel-infra.org/2071
project: packages/centos6/libqb
branch: 6.1
author: Dmitry Burmistrov
committer: Dmitry Burmistrov
subject: LP #1381062. Create libqb >= 0.17.0 package
status: change-merged

Files placed on repository:
libqb-0.17.0-1.mira1.x86_64.rpm
libqb-debuginfo-0.17.0-1.mira1.x86_64.rpm
libqb-devel-0.17.0-1.mira1.x86_64.rpm

Changeset merged. Package placed on primary repository
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.1-stable/centos

OSCI Robot (oscirobot) wrote :

RPM package libqb has been built for project packages/centos6/libqb
Package version == 0.17.1, package release == 1

Changeset: https://review.fuel-infra.org/2068
project: packages/centos6/libqb
branch: master
author: Bart?omiej Piotrowski
committer: Bart?omiej Piotrowski
subject: Update libqb-0.17.0 to 0.17.1
status: patchset-created

Files placed on repository:
libqb-0.17.1-1.mira1.x86_64.rpm
libqb-debuginfo-0.17.1-1.mira1.x86_64.rpm
libqb-devel-0.17.1-1.mira1.x86_64.rpm

NOTE: Changeset is not merged, created temporary package repository.
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-master-2068/centos

OSCI Robot (oscirobot) wrote :

RPM package libqb has been built for project packages/centos6/libqb
Package version == 0.17.1, package release == 1

Changeset: https://review.fuel-infra.org/2074
project: packages/centos6/libqb
branch: 6.1
author: Artem Silenkov
committer: Artem Silenkov
subject: Update libqb-0.17.0 to 0.17.1
status: patchset-created

Files placed on repository:
libqb-0.17.1-1.mira1.x86_64.rpm
libqb-debuginfo-0.17.1-1.mira1.x86_64.rpm
libqb-devel-0.17.1-1.mira1.x86_64.rpm

NOTE: Changeset is not merged, created temporary package repository.
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.1-stable-2074/centos

OSCI Robot (oscirobot) wrote :

RPM package libqb has been built for project packages/centos6/libqb
Package version == 0.17.1, package release == 1

Changeset: https://review.fuel-infra.org/2074
project: packages/centos6/libqb
branch: 6.1
author: Artem Silenkov
committer: Artem Silenkov
subject: Update libqb-0.17.0 to 0.17.1
status: change-merged

Files placed on repository:
libqb-0.17.1-1.mira1.x86_64.rpm
libqb-debuginfo-0.17.1-1.mira1.x86_64.rpm
libqb-devel-0.17.1-1.mira1.x86_64.rpm

Changeset merged. Package placed on primary repository
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.1-stable/centos

OSCI Robot (oscirobot) wrote :

RPM package libqb has been built for project packages/centos6/libqb
Package version == 0.17.1, package release == 1

Changeset: https://review.fuel-infra.org/2068
project: packages/centos6/libqb
branch: master
author: Bart?omiej Piotrowski
committer: Bart?omiej Piotrowski
subject: Update libqb-0.17.0 to 0.17.1
status: change-merged

Files placed on repository:
libqb-0.17.1-1.mira1.x86_64.rpm
libqb-debuginfo-0.17.1-1.mira1.x86_64.rpm
libqb-devel-0.17.1-1.mira1.x86_64.rpm

Changeset merged. Package placed on primary repository
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-master/centos

Changed in mos:
status: Confirmed → Fix Committed
Bogdan Dobrelya (bogdando) wrote :

Reopening because of incorrect workflow. 'Fix committed' should be set when packages get here:
http://mirror.fuel-infra.org/fwm/6.1/

Changed in mos:
assignee: Bartlomiej Piotrowski (bpiotrowski) → Fuel OSCI Team (fuel-osci)
status: Fix Committed → Confirmed
Roman Vyalov (r0mikiam) wrote :
Changed in mos:
assignee: Fuel OSCI Team (fuel-osci) → MOS Linux (mos-linux)
Changed in mos:
assignee: MOS Linux (mos-linux) → Aleksander Mogylchenko (amogylchenko)
Kyrylo Romanenko (kromanenko) wrote :

Verified version of libqb package on CentOS env on MOS
VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "6.1"
  openstack_version: "2014.2.2-6.1"
  api: "1.0"
  build_number: "395"
  build_id: "2015-05-08_11-08-49"
  nailgun_sha: "46f55c293e4540d31bcaa6ca3fba77235fb27537"
  python-fuelclient_sha: "af6c9c3799b9ec107bcdc6dbf035cafc034526ce"
  astute_sha: "6a4dcd11c67af2917815f3678fb594c7412a4c97"
  fuel-library_sha: "f385d6a58298c702f8d4f14c452dcffdc0b1e2a3"
  fuel-ostf_sha: "740ded337bb2a8a9b3d505026652512257375c01"
  fuelmain_sha: "3eca5e8f7ca6a83faff5feeca92c21cff31c0af1"

# yum info libqb
Installed Packages
Name : libqb
Arch : x86_64
Version : 0.17.0

Changed in mos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers