[mos] Error in neutron-server log: neutron.common.legacy [-] Skipping unknown group key: firewall_driver

Bug #1261330 reported by Anastasia Palkina on 2013-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Low
Matthew Mosesohn
Mirantis OpenStack
Low
MOS Neutron

Bug Description

ISO #142
"release": "4.0",
"nailgun_sha": "e5c0e954d6d03ba9fd857f1f7a662a6386099232",
"ostf_sha": "c1c353909cd1a0af018bbe89fb12570db6b09969",
"astute_sha": "75aa0877cba772f409d3cef4f36ba2ec1b8b603b",
"fuellib_sha": "0ca5d615edb7e7541dfe0fcb646a879f80c1e8b0"

1. Create new environment (CentOS, simple)
2. Choose VLAN segmentation, Cinder LVM and Cinder volumes
3. Add controller+ceph, compute, cinder+ceph
4. Start deployment. It was successful
5. Error in neutron-server log: neutron.common.legacy [-] Skipping unknown group key: firewall_driver

Anastasia Palkina (apalkina) wrote :
Mike Scherbakov (mihgen) wrote :

How does it affect users?

Sergey Vasilenko (xenolog) wrote :

I think it's give only red-error-lines in Neutron ligs in UI

Changed in fuel:
status: New → Confirmed
Mike Scherbakov (mihgen) on 2013-12-16
Changed in fuel:
assignee: Sergey Vasilenko (xenolog) → nobody
Changed in fuel:
importance: Undecided → Low
Dmitry Pyzhov (dpyzhov) on 2014-01-16
Changed in fuel:
milestone: 4.0 → 4.1
Mike Scherbakov (mihgen) on 2014-02-21
Changed in fuel:
milestone: 4.1 → 5.0
Changed in fuel:
milestone: 5.0 → 5.1
Ilya Shakhat (shakhat) on 2014-06-20
Changed in mos:
assignee: nobody → MOS Neutron (mos-neutron)
milestone: none → 5.1
Ilya Shakhat (shakhat) wrote :

The issue is fixed in upstream master, stable/icehouse and stable/havana branches: https://review.openstack.org/#/c/80379/
Thus not applicable for 5.0.1 or later

Changed in mos:
status: New → Fix Committed
Matthew Mosesohn (raytrac3r) wrote :

Assigining to myself so I can confirm Fuel side fix.

Changed in fuel:
assignee: nobody → Matthew Mosesohn (raytrac3r)
tags: added: neutron
Dmitry Ilyin (idv1985) on 2014-07-15
summary: - Error in neutron-server log: neutron.common.legacy [-] Skipping unknown
- group key: firewall_driver
+ [mos] Error in neutron-server log: neutron.common.legacy [-] Skipping
+ unknown group key: firewall_driver
Changed in fuel:
status: Confirmed → Fix Committed
Anastasia Palkina (apalkina) wrote :

Verified on ISO #11

"build_id": "2014-09-17_21-40-34", "ostf_sha": "64cb59c681658a7a55cc2c09d079072a41beb346", "build_number": "11", "auth_required": true, "api": "1.0", "nailgun_sha": "eb8f2b358ea4bb7eb0b2a0075e7ad3d3a905db0d", "production": "docker", "fuelmain_sha": "8ef433e939425eabd1034c0b70e90bdf888b69fd", "astute_sha": "f5fbd89d1e0e1f22ef9ab2af26da5ffbfbf24b13", "feature_groups": ["mirantis"], "release": "5.1", "release_versions": {"2014.1.1-5.1": {"VERSION": {"build_id": "2014-09-17_21-40-34", "ostf_sha": "64cb59c681658a7a55cc2c09d079072a41beb346", "build_number": "11", "api": "1.0", "nailgun_sha": "eb8f2b358ea4bb7eb0b2a0075e7ad3d3a905db0d", "production": "docker", "fuelmain_sha": "8ef433e939425eabd1034c0b70e90bdf888b69fd", "astute_sha": "f5fbd89d1e0e1f22ef9ab2af26da5ffbfbf24b13", "feature_groups": ["mirantis"], "release": "5.1", "fuellib_sha": "d9b16846e54f76c8ebe7764d2b5b8231d6b25079"}}}, "fuellib_sha": "d9b16846e54f76c8ebe7764d2b5b8231d6b25079"

Changed in fuel:
status: Fix Committed → Fix Released
Changed in mos:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers