there should be no popup for private/teletext

Bug #415031 reported by ThijsVermeir
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Elisa Media Center
Invalid
Undecided
Jonathan Rauprich
Moovida
Invalid
Medium
Unassigned

Bug Description

When playing a mpegts stream with a teletext stream, there is always a popup that there is no decoder for private/teletext. However by default the user is not interested in private/teletext, so there should not be a popup for this.

Related branches

Michał Sawicz (saviq)
Changed in elisa:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Olivier Tilloy (osomon) wrote :

Can you please link to such a stream?

Revision history for this message
Michał Sawicz (saviq) wrote :

I can upload something when I get back home today.

Revision history for this message
ThijsVermeir (thijsvermeir) wrote :

http://people.fluendo.com/thijs/teletext.mpeg

contains: audio, video and txt

Revision history for this message
Olivier Tilloy (osomon) wrote :

Do you know what the gstreamer element to decode teletext is?
I cannot observe the popup with the linked video, so I guess I have this decoder installed.

Revision history for this message
ThijsVermeir (thijsvermeir) wrote :

As far as I know there is no teletext decoder except for this[1]. I'm running GStreamer git so maybe that is why you are not seeing these popup's.

[1] http://github.com/sebp/gst-teletext/tree

Revision history for this message
Michał Sawicz (saviq) wrote :

I have been seeing the popups before, too, on gstreamer from Packman's RPMs, but I can't reproduce anymore.

Revision history for this message
Olivier Tilloy (osomon) wrote :

I can reproduce with the GStreamer that comes with Ubuntu Karmic.

Revision history for this message
Jonathan Rauprich (joni-noplu) wrote :

This is fixed in the following branch:
https://code.launchpad.net/~joni-noplu/elisa/teletext_fix

Olivier Tilloy (osomon)
Changed in elisa:
assignee: nobody → joni (joni-noplu)
status: New → Fix Committed
Revision history for this message
dino99 (9d9) wrote :

The latest free moovida 1.09 does not get any maintenance since a while. Now moovidadb.com is supporting Linux and support can be found at : http://www.fluendo.com/faq/

Changed in moovida:
status: Confirmed → Invalid
Changed in elisa:
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers