[linux] Coherence plugin fails to load, unmet dependencies: Twisted>=2.5.0

Bug #401669 reported by Olivier Tilloy
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released

Bug Description

On my dev box running ubuntu intrepid, the coherence plugin fails to load with the following warning:

plugin elisa-plugin-coherence has the following unmet dependencies: Twisted>=2.5.0 (elisa/core/plugin_registry.py:362)

The cause of the problem lies in coherence itself that declares a hard dependency on twisted (while in fact in only depends on the twisted-core and twisted-web subsets). The plugin registry, built on top of pkg_resources, refuses to load the plugin because it cannot find egg info for twisted.

If I manually install the python-twisted package, that solves the issue.

Olivier Tilloy (osomon)
Changed in elisa:
importance: Undecided → Medium
status: New → Triaged
Changed in coherence:
status: Unknown → New
Changed in coherence:
status: New → Fix Released
Revision history for this message
Olivier Tilloy (osomon) wrote :

Karmic packages for the upcoming 1.0.8 have been updated and now include an explicit dependency on python-twisted to work around the problem that is still in coherence's package.

Revision history for this message
Olivier Tilloy (osomon) wrote :

A visible consequence for the end-user is bug #461191.

Revision history for this message
dino99 (9d9) wrote :

The latest free moovida 1.09 does not get any maintenance since a while. Now moovidadb.com is supporting Linux and support can be found at : http://www.fluendo.com/faq/

Changed in moovida:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.