lirc plugin is missing delay and repeat settings

Bug #264113 reported by Uco on 2008-09-02
52
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Moovida
High
Fernando Casanova
Declined for 0.5 by Olivier Tilloy

Bug Description

When pressing a button on the remote it gets executed 4 times which make it impossible to navigate with it.
In early versions of the lirc plugin there was a delay and repeat setting in the Elisa config file, but it seems to have disappeared with the 0.5 branch of Elisa.

Uco (ucomesdag) on 2008-09-02
Changed in elisa:
status: New → Confirmed
Olivier Tilloy (osomon) on 2008-09-03
Changed in elisa:
milestone: none → 0.5.x
status: Confirmed → New
pixel_juice (benjarvis) wrote :

Confirmed this on my install. I'm running Elisa 0.5.9 on Ubuntu Hardy Heron.

I have a StreamZap remote.

Ben

Changed in elisa:
status: New → Confirmed
Leo (lightmantrek) wrote :

Confirmed here too, ubuntu hardy, elisa 0.5.9, MCE USB Phillips receiver and RC6 remote controller, streamzap

using IRW i can see that actually the remote is issuing the commands very fast one after another (you have to do a very short touch on the remote button to just transmit 1 command)

there is a hack in the forum [url=https://elisa.fluendo.com/forums/viewtopic.php?id=735]https://elisa.fluendo.com/forums/viewtopic.php?id=735[/url] that solves the problem, will this be included as standard fix?

Leo (indkt).

kenny-x (live-kenny) wrote :

I had this problem on two seperate Linux machines, with ubuntu hardy installed. The fix is indicated by Leo was implemented by me, and fixed the problem for both pc's.

Stephan Roolvink (kenny_X)

pixel_juice (benjarvis) wrote :

Can someone please assign an importance to this bug? I would love to see this get fixed in the next update.

Ben

Olivier Tilloy (osomon) on 2008-10-02
Changed in elisa:
importance: Undecided → High
pixel_juice (benjarvis) wrote :

Thank you so much Mr. Tilloy! I look forward to more precise button pushing.

Ben

willie (rwillman) wrote :

I also had the same problem. The updated lirc_input.py from the forums did the trick for me too. Elisa 0.5.12 on Ubuntu Hardy.

Canek Peláez Valdés (caneko) wrote :

Just attaching the solution from the forums in form of a patch.

Adam Williamson (awilliamson) wrote :

The repeat detection patch at https://elisa.fluendo.com/quality/review/request/%<email address hidden>%3E works well for me (Harmony 880 remote acting as a Hauppauge remote from an old WinTV card).

Canek Peláez Valdés (caneko) wrote :

The same patch from my last post, but with a little modification; it now forces the delay value of the timer to be a float. Without this, lots of errors will get in the logs, and the patch will not work.

Tom Kistner (tom-duncanthrax) wrote :

Patch above didn't work for me - I think the code path for blocked repeated events is incomplete. Changed patch attached.

Tom Kistner (tom-duncanthrax) wrote :

Grrr ... I shouldn't manually edit Python patch files. Here's yet another one.

spiggott (spiggott) wrote :

The attached patch to lirc_input.py corrects this problem more simply, by telling it to ignore up to 5 repetitions resulting from holding down a button before going into repeat mode. No timing involved. It defaults to a repeat value of 5, which gives good results with the streamzap remote, but it will respect values made in the elisa conf file by setting

repeat = '5'

in the [lirc.lirc_input:LircInput] section, substituting your own value for 5.

Tested only with the streamzap remote. Will only work with remotes that generate the repeat number.

Anders Østhus (grapz) wrote :

Hi

I have an Soundgraph IR/LCD (15c2 0038).

My remote sends the same command twice when I press a button.
I tried both of those patches posted here, but no joy came from it, so I modified Tom Kistner's patch to work for me.
It's a bit 'hacky', but atleast my remote is usable now ;)

Main things about the patch:
Repeat: value that says how many extra times the remote sends the command

Then I count number of commands received and checks if they are equal to the last.

Anders Østhus (grapz) wrote :

Heh, a bit late.

Change in patch: Changed default value of 'repeat' to 1 (the value soundgraph needs).

Anders Østhus (grapz) wrote :

Several hours later...

You can ignore my patch above. The fault was actually in my lirc config file.
Don't know what did it, but somehow all commands came up twice, but not as repeats, just two of the same command. That's why the repeat patch didn't work.

Well, I figured it out, and as I said, the patch ain't needed for the Soundgrapz 15c2 0038.

Steve Kondik (cyanogen) wrote :

I've been applying this patch to my local copy for the last 10 releases or so.. It's pretty much required with a basic MCE remote because it's too hard to navigate with the fast repeat. Please consider including it!

Olivier Tilloy (osomon) wrote :

@Steve: the LIRC remote issue is quite a tricky one due to the number of different configurations and behaviours. We ought to proceed cautiously here, it wouldn't make sense to merge in a patch that fixes the issue for some and breaks it for others.
Can you please clarify what patch you are talking about? (ideally regenerate it against the latest development branch at lp:elisa and attach it here).

Changed in elisa:
milestone: 0.5.x → none
Steve Kondik (cyanogen) wrote :

Attaching latest patch for LIRC repeat & delay options.

Uco (ucomesdag) wrote :

@Steve: Can you please attach a patch for the latest 0.5.37... upgraded to 9.04 and it stopped working even after manually applying the patch... Thnx

Jordy Potman (jordypotman) wrote :

@Uco: Which lirc_input.py did you patch? The one in /usr/share/pyshared/elisa/plugins/lirc ? Because since 0.5.36 there is an updated lirc plugin that is distributed via the plugin repository which is installed as ~/.elisa-0.5/plugins/elisa_plugin_lirc-0.2.egg and which overrides the one in /usr/share/pyshared/elisa/plugins/lirc .

As a workaround I disabled automatic plugin updating (change auto_update_plugins = True in ~/.elisa-0.5/elisa_0_5_6.conf to auto_update_plugins = False) and moved ~/.elisa-0.5/plugins/elisa_plugin_lirc-0.2.egg to ~/.elisa-0.5/plugins/elisa_plugin_lirc-0.2.egg.disabled . After starting Elisa choose Later when asked if you want to install the update that is available and Elisa should use your patched lirc_input.py in /usr/share/pyshared/elisa/plugins/lirc again.

P.S. Elisa's lirc plugin is also unusable for me with a Logitech Harmony 525 acting as a Hauppauge PVR 350 remote without Steve Kondik's patch above.

Uco (ucomesdag) wrote :

@Jordy Potman: Dude I just ficked the repeat stuff, your post made me fidle with my Harmony 555 (PVR 350) and it works now beside's the delay is real short, it's useable without patching. I have a french version of the logitech software so you might have to search a bit.

What i did: On the mean screen go to the second tab (Equipment or whatever it's called in the english version), go to your device and go for the second button (I guess? In french it's called "Depanage"). It will list a checklist (for me it's the before last option) and one of these options brings you to an other checklist (with options 0 to 5) and set this to 0 (this actualy the number of times a button is repeated by the remote)... and voila it works... Only the delay is realy short, if you hold the button longer then a second it will start repeating... But it's functional!

yyoyo (lionel.martin) on 2009-05-01
Changed in elisa:
milestone: none → 0.5.99
Adam Williamson (awilliamson) wrote :

FWIW, I've been carrying one of the patches from this bug in the Mandriva Elisa packages for a while, now, and had no problems either myself or reported by anyone who uses it.

http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/elisa-plugins-ugly/current/SOURCES/elisa-plugins-ugly-0.5.19-lirc_repeat.patch?view=log

still, it's obviously a tweak-susceptible area. With that patch, repeat works for me, but the 'scroll speed' is quite slow...occasionally it speeds up for about four or five entries then slows down again. So something's not quite right.

(If my page up / page down bug were fixed this would be much less of an issue.)

Olivier Tilloy (osomon) wrote :

The behaviour of the LIRC plugin has been greatly improved regarding repeat and delay in Moovida 1.0.0.
Can you guys try it out and give your feedback?
If positive we'll close the bug report.

Changed in elisa:
milestone: 0.5.99 → none
Ryan Steele (rgsteele) wrote :

The repeat detection code in the LIRC plugin in Moovida 1.0.1 does not work correctly. It does not take into consideration the amount of time elapsed between the current button press and the previous button press when one button is pressed repeatedly.

Consider the case where the delay is set to 0.6 and I press the right arrow button twice, with one second between presses. The first button press registers a single event correctly, but multiple events are registered with the second button press. As far as the program is concerned, the button has been held down (because over 0.6 seconds have elapsed since the first button press), despite the fact that one second has elapsed since the previous button press.

I believe that spiggott's patch is the correct solution. I have implemented it in my branch of Moovida and confirmed that it functions correctly. I am using a Windows MCE USB remote. I have cleaned up his patch a little and applied it against the most recent version of lirc_input.py. I attach it below.

hads (hads) wrote :

I can confirm that Moovida 1.0.1 still has issues, I'm using an MCE USB remote and was seeing repeats etc. The patch from Ryan Steele above seems to fix things perfectly here.

Cheers,

hads

Philippe Normand (philn) wrote :

The problem is that in some cases (apple remote) the repeat value of the LIRC event can't be trusted reliably.

tags: added: remote-control
event.riga (event-riga) wrote :

I use usb mce with Philips remote and had this problem as well. I've implemented the same solution as spiggott proposed and it works perfectly for me.

Fernando Casanova (fcasanova) wrote :

Hi all,

I implemented a fix for this bug thanks to Jeremy Jongsma's merge request. You can test it by downloading and using this egg:
http://people.fluendo.com/fcasanova/elisa_plugin_lirc-0.5.egg

Could you please tell me what you think?

   Cheers,

     F

Changed in elisa:
status: Confirmed → In Progress
Olivier Tilloy (osomon) on 2009-10-07
Changed in elisa:
assignee: nobody → Fernando Casanova (fcasanova)
Fernando Casanova (fcasanova) wrote :

To be released with 1.0.8

Changed in elisa:
milestone: none → 1.0.8
status: In Progress → Fix Committed
Olivier Tilloy (osomon) on 2009-11-03
Changed in moovida:
status: Fix Committed → Fix Released
To post a comment you must log in.