Moovida (formerly Elisa), a universal and user-friendly media center

Elisa not compatible with Twisted 8.0 onwards

Reported by Tony on 2008-04-08
4
Affects Status Importance Assigned to Milestone
Moovida
Medium
Unassigned
Debian
Fix Released
Unknown

Bug Description

Elisa don't detect media with twisted 8.0.1-1 on debian sid. See attachment file for more details.

Tony (tony-ducrocq) wrote :
Changed in elisa:
assignee: nobody → alessandro.decina
importance: Undecided → Critical
Changed in elisa:
assignee: alessandro.decina → philn
status: New → In Progress
Philippe Normand (philn) on 2008-05-26
Changed in elisa:
assignee: philn → nobody
milestone: none → 0.3.6
Philippe Normand (philn) on 2008-05-26
Changed in elisa:
assignee: nobody → philn
Changed in elisa:
milestone: 0.3.6 → 0.5.1
yyoyo (lionel.martin) on 2008-07-01
Changed in elisa:
importance: Critical → Low
yyoyo (lionel.martin) on 2008-07-01
Changed in elisa:
status: In Progress → Confirmed
Philippe Normand (philn) on 2008-07-01
Changed in elisa:
assignee: philn → nobody
yyoyo (lionel.martin) on 2008-07-09
Changed in elisa:
milestone: 0.5.1 → 0.5.2
Florian Boucault (fboucault) wrote :

Gst metadata is not an issue anymore.
Last issue regarding Twisted 8.0 compatibility has to do with the http client.

Changed in elisa:
assignee: nobody → lightyear
importance: Low → Medium
Benjamin Kampmann (lightyear) wrote :

We have a fixed http client for elisa/0.5 but we have since they change the behaviour of some parts sligthly, we need to go through all our code and fix the implementations on top of the http client as well. Like the commit http://bazaar.launchpad.net/~elisa-developers/elisa/http_client/revision/63 shows:

{{{#!python
read_dfr = response.stream.read()
}}}

needs to be changed to

{{{#!python
read_dfr = defer.maybeDeferred(
          BufferedStream(response.stream).readExactly)
}}}

Olivier Tilloy (osomon) on 2009-01-20
Changed in elisa:
assignee: lightyear → nobody
Olivier Tilloy (osomon) on 2009-05-27
Changed in elisa:
milestone: 0.5.x → none
Florian Boucault (fboucault) wrote :

I believe the issue is no more in Moovida upstream. On Ubuntu Karmic with Twisted 8.2 everything works fine.

Changed in elisa:
status: Confirmed → Fix Released
Olivier Tilloy (osomon) wrote :

Note that our windows build currently ships with Twisted 2.5.0. See bug #387847 for more details.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.