current form implementation process fails to start

Bug #1357831 reported by Stephen Salser on 2014-08-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Monkey Studio IDE
Undecided
Unassigned

Bug Description

I already made sure that the environment variables has a working path to pyuic4. (This is on a mac running 10.9.4.)

Here is what the environment variables path looks like: /Users/stephensalser/anaconda/pkgs/pyqt-4.10.4-py27_0/bin:/Users/stephensalser/anaconda/bin:/usr/bin:/bin:/usr/sbin:/sbin (First two paths both have pyuic4 in them.)

Here is what the whole error message looks like:

* Error : 'Generate current form implementation'
* Command : pyuic4 "/Users/stephensalser/Documents/Monkey Studio/Projects/HelloWorld3/mainwindow.ui" -o "/Users/stephensalser/Documents/Monkey Studio/Projects/HelloWorld3/mainwindow.ui".py
* Working Directory: /Users/stephensalser/Documents/Monkey Studio/Projects/HelloWorld3
* Error : #0
The process failed to start. Either the invoked program is missing, or you may have insufficient permissions to invoke the program.

I also tried entering the command directly into the terminal window after getting into the working directory and got this error message.

Traceback (most recent call last):
  File "/Users/stephensalser/anaconda/lib/python2.7/site-packages/PyQt4/uic/pyuic.py", line 31, in <module>
    from PyQt4 import QtCore
ImportError: No module named PyQt4
Stephen-Salsers-iMac-3:HelloWorld3

Please help me figure out what to do!

Stephen Salser (ssalser) wrote :

P.S. I believe that PyQt4 has been properly installed because I can run these lines in python both from the terminal window and also in the interpreter of MonkeyStudio with no problem. ( from PyQt4.QtCore import *, from PyQt4.QtGui import * )

Stephen Salser (ssalser) wrote :

I tried to fix this by completely removing the Anaconda python install from my computer and installing python and pyqt myself.

I get exactly the same problem with the different python install.

The project works fine when run under the interpreter, but MkS will not generate the current form implementation.

I have checked the path to pyuic4 in the environmental variables and it is correct.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers