Monasca Log Management plugin install fails on ubuntu14.04

Bug #1648357 reported by sanjana
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Monasca
New
Undecided
Unassigned

Bug Description

I am trying to install the monasca log-api devstack plugin on Ubuntu 14.04LTS instance.
The contents of my local.conf is as below:

MONASCA_API_IMPLEMENTATION_LANG=${MONASCA_API_IMPLEMENTATION_LANG:-python}
MONASCA_PERSISTER_IMPLEMENTATION_LANG=${MONASCA_PERSISTER_IMPLEMENTATION_LANG:-python}
MONASCA_METRICS_DB=${MONASCA_METRICS_DB:-influxdb}

# This line will enable all of Monasca.
enable_plugin monasca-api git://git.openstack.org/openstack/monasca-api
enable_plugin monasca-log-api https://github.com/openstack/monasca-log-api.git

enable_service rabbit mysql key horizon tempest

Further when i run ./stack.sh it fails with the following error log:
2016-12-08 08:50:06.016 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:398 : sudo groupadd --system kafka
2016-12-08 08:50:06.022 | groupadd: group 'kafka' already exists
2016-12-08 08:50:06.024 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:398 : true
2016-12-08 08:50:06.027 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:400 : sudo useradd --system -g kafka kafka
2016-12-08 08:50:06.032 | useradd: user 'kafka' already exists
2016-12-08 08:50:06.035 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:400 : true
2016-12-08 08:50:06.037 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:402 : sudo tar -xzf /home/ubuntu/devstack/files/kafka_2.9.2-0.8.1.1.tgz -C /opt
2016-12-08 08:50:06.224 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:404 : sudo ln -sf /opt/kafka_2.9.2-0.8.1.1 /opt/kafka
2016-12-08 08:50:06.232 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:406 : sudo cp -f /opt/stack/monasca-api/devstack/files/kafka/kafka-server-start.sh /opt/kafka_2.9.2-0.8.1.1/bin/kafka-server-start.sh
2016-12-08 08:50:06.240 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:408 : sudo cp -f /opt/stack/monasca-api/devstack/files/kafka/kafka.service /etc/systemd/system/kafka.service
2016-12-08 08:50:06.249 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:410 : sudo chown root:root /etc/systemd/system/kafka.service
2016-12-08 08:50:06.256 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:412 : sudo chmod 644 /etc/systemd/system/kafka.service
2016-12-08 08:50:06.264 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:414 : sudo mkdir -p /var/kafka
2016-12-08 08:50:06.273 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:416 : sudo chown kafka:kafka /var/kafka
2016-12-08 08:50:06.281 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:418 : sudo chmod 755 /var/kafka
2016-12-08 08:50:06.289 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:420 : sudo rm -rf /var/kafka/lost+found
2016-12-08 08:50:06.297 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:422 : sudo mkdir -p /var/log/kafka
2016-12-08 08:50:06.305 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:424 : sudo chown kafka:kafka /var/log/kafka
2016-12-08 08:50:06.314 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:426 : sudo chmod 755 /var/log/kafka
2016-12-08 08:50:06.324 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:428 : sudo ln -sf /opt/kafka/config /etc/kafka
2016-12-08 08:50:06.335 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:430 : sudo cp -f /opt/stack/monasca-api/devstack/files/kafka/log4j.properties /etc/kafka/log4j.properties
2016-12-08 08:50:06.347 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:432 : sudo chown kafka:kafka /etc/kafka/log4j.properties
2016-12-08 08:50:06.360 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:434 : sudo chmod 644 /etc/kafka/log4j.properties
2016-12-08 08:50:06.369 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:436 : sudo cp -f /opt/stack/monasca-api/devstack/files/kafka/server.properties /etc/kafka/server.properties
2016-12-08 08:50:06.377 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:438 : sudo chown kafka:kafka /etc/kafka/server.properties
2016-12-08 08:50:06.386 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:440 : sudo chmod 644 /etc/kafka/server.properties
2016-12-08 08:50:06.393 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:442 : [[ -n 127.0.0.1 ]]
2016-12-08 08:50:06.395 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:443 : sudo sed -i 's/host\.name=127\.0\.0\.1/host.name=127.0.0.1/g' /etc/kafka/server.properties
2016-12-08 08:50:06.404 | ++ /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:446 : sudo systemctl enable kafka
2016-12-08 08:50:06.408 | sudo: systemctl: command not found
2016-12-08 08:50:06.410 | + /opt/stack/monasca-api/devstack/plugin.sh:install_kafka:1 : exit_trap
2016-12-08 08:50:06.412 | + ./stack.sh:exit_trap:487 : local r=1
2016-12-08 08:50:06.414 | ++ ./stack.sh:exit_trap:488 : jobs -p
2016-12-08 08:50:06.416 | + ./stack.sh:exit_trap:488 : jobs=
2016-12-08 08:50:06.418 | + ./stack.sh:exit_trap:491 : [[ -n '' ]]
2016-12-08 08:50:06.420 | + ./stack.sh:exit_trap:497 : kill_spinner
2016-12-08 08:50:06.422 | + ./stack.sh:kill_spinner:383 : '[' '!' -z '' ']'
2016-12-08 08:50:06.424 | + ./stack.sh:exit_trap:499 : [[ 1 -ne 0 ]]
2016-12-08 08:50:06.426 | + ./stack.sh:exit_trap:500 : echo 'Error on exit'
2016-12-08 08:50:06.426 | Error on exit
2016-12-08 08:50:06.427 | + ./stack.sh:exit_trap:501 : generate-subunit 1481186831 175 fail
2016-12-08 08:50:06.855 | + ./stack.sh:exit_trap:502 : [[ -z /opt/stack/logs ]]
2016-12-08 08:50:06.857 | + ./stack.sh:exit_trap:505 : /home/ubuntu/devstack/tools/worlddump.py -d /opt/stack/logs
2016-12-08 08:50:07.215 | + ./stack.sh:exit_trap:511 : exit 1

Further it is told that The Monasca DevStack plugin works on Ubuntu 16.04 (Xenial). How can i create a test environment when the versions are conflicting for monasca plugin and monasca log-api plugin

sanjana (sanjana)
summary: - Monasca log-api plugin install fails
+ Monasca Log Management plugin install fails on ubuntu14.04
sanjana (sanjana)
description: updated
Revision history for this message
Ryan (ryan-brandt) wrote :

Has this been tested with both in Xenial now? I believe the everything should be operating on Xenial.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers