hyperref warning messages when compiling template.tex

Reported by Philip Leifeld on 2012-08-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
moderncv
Low
Xavier Danaux

Bug Description

I have just installed the most recent version of moderncv, version 1.1.2 (9 Aug 2012).

When I compile the included template.tex, I get a couple of warning messages, mostly related to the hyperref package:

/usr/share/texmf-texlive/tex/latex/hyperref/hyperref.sty:0: Option `pdfpagelabels' is turned off(hyperref) because \thepage is undefined.
./template.tex:51: Option `pdfpagelabels' has already been used,(hyperref) setting the option has no effect on input line 51. Option `pdfpagelabels' has already been used,(hyperref) setting the option has no effect
./template.tex:0: \footskip is too small (30.0pt):Make it at least 39.19379pt.
./template.tex:0: \footskip is too small (30.0pt):Make it at least 39.19379pt.
./template.tex:0: \footskip is too small (30.0pt):Make it at least 39.19379pt.

I am running texlive on Ubuntu Linux 11.10. It would be very nice if this could be fixed. I have no clue if the problem affects the layout.

Edit: It seems you have to delete line 134 from moderncv.cls:

pdfpagelabels = false,% to avoid a warning setting it automatically to false anyway, because hyperref detects \thepage as undefined (why?)

Then replace line 128:

\RequirePackage[unicode]{hyperref}

with the following line:

\RequirePackage[unicode,pdfpagelabels=false]{hyperref}

This fixed the hyperref issues for me. Would you like to commit this change in your repository? It would be nice to have it updated in the next version.

Now I still see the \footskip warnings though. Any idea how that can be solved? Thanks!

Related branches

Philip Leifeld (leifeld) on 2012-08-10
summary: - hyperref warning messages when compiling example.tex
+ hyperref warning messages when compiling template.tex
Philip Leifeld (leifeld) on 2012-08-10
description: updated
Xavier Danaux (xdanaux) on 2012-08-11
Changed in moderncv:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Xavier Danaux (xdanaux)
Xavier Danaux (xdanaux) wrote :

Hi Philip,

Thanks for the fix for the hyperref warning! I already removed a couple other warnings some time ago, but was still stuck with this one indeed. I'll commit it asap.

As for the footskip warning, I'll investigate, but I am afraid it might be complicated, as one can't know the content of the footer before the end of the preamble. I guess you could try to pre-render the footer and adapt the geometry of the page as of the end of the preamble, but I haven't looked at it yet.

Changed in moderncv:
status: Confirmed → Fix Committed
Xavier Danaux (xdanaux) on 2012-08-11
Changed in moderncv:
status: Fix Committed → Fix Released
Philip Leifeld (leifeld) wrote :

Great! Thanks for releasing it so quickly!

You may want to add a new bug report for the footskip warning since this has not been resolved yet.

One question: does the footskip warning have any negative consequences for the layout? Or does it just complain about something that is actually working well and I can safely ignore the warning?

Xavier Danaux (xdanaux) wrote :

It shouldn't; I just ran a couple of tests on the "casual" style and didn't encounter any issue, with or without warning.

The only case that comes to my mind that could potentially create an issue is when the footskip is large enough to hold the footer for the resume, but needs to be enlarged to hold the one for the letter (that contains the name of the applicant in addition). In that case, I don't know if the two footers will still be perfectly aligned. I tried to test out that case, but wasn't actually able to reproduce it...

Francisco Lopes (oblita) wrote :

coming from tex.stackexchange, I'm getting the same problems with latest moderncv from repository. Adding hyperref like:

\usepackage[colorlinks=true, urlcolor=color1]{hyperref}

cause the same:

Package hyperref Warning: Option `pdfpagelabels' is turned off
(hyperref) because \thepage is undefined.

Francisco Lopes (oblita) wrote :

by the way, I unable to import babel greek now, getting issues like this http://tex.stackexchange.com/questions/140155/moderncv-and-babel-spanish-cause-missing-endcsname-error.

Francisco Lopes (oblita) wrote :

nevermind the hyperref issue, I got it working using \AfterPreamble \hypersetup: http://tex.stackexchange.com/questions/79395/option-clash-for-hyperref-package

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers