Comment 82 for bug 1057186

@Luiz Sorry, by 0.9, i Meant Network manager and the fixed version of modem manager is 0.6.1...

Actually, in my machine which is AMD64 i have 0.7 working fine and it was installed through @Aleksander ppa (So maybe you have an I368 architecture which still does not have a proper build):
$ dpkg -s modemmanager
Package: modemmanager
Status: install ok installed
Priority: optional
Section: net
Installed-Size: 1959
Maintainer: Alexander Sack <email address hidden>
Architecture: amd64
Version: 0.7.990~git201304122141.3398-0~pkg191~raring1
Depends: libc6 (>= 2.14), libglib2.0-0 (>= 2.31.8), libgudev-1.0-0 (>= 146), libmm-glib0, libqmi-glib0 (>= 1.0), upstart-job
Recommends: usb-modeswitch
Conffiles:
 /etc/init/modemmanager.conf 9f1575f76aa0c94466762cb2ca964cec
 /etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf 91eb7792b1dd55d40bc36cff94c96aac
 /etc/dbus-1/system.d/org.freedesktop.ModemManager.conf 6a92263b78fc73d5252171dc0ff9c3ea obsolete
Description: D-Bus service for managing modems
 Provides a D-Bus interface to communicate with mobile broadband (GSM, CDMA,
 UMTS, ...) cards. Implements a loadable plugin interface to add work-arounds
 for non standard devices. Also provides patches to use networkmanager (and
 the applet) with modem manager.
 .
 Git Repository: http://cgit.freedesktop.org/ModemManager/ModemManager/