HildonGetPasswordDialog dialogs do not display properly

Bug #146102 reported by AaronL
4
Affects Status Importance Assigned to Milestone
Moblin UI Framework
Fix Released
Critical
Bob Spencer

Bug Description

Bug detailed description:
--------------------------
HildonGetPasswordDialog dialogs do not display properly. The following code can be used to create and display a dialog (with slight modifications):

  GtkWidget *dialog =
    hildon_get_password_dialog_new(GTK_WINDOW(mainview->data->main_view), FALSE);

  gtk_dialog_run(GTK_DIALOG(dialog);

I have attached a screenshot that shows what I mean. It should be easy enough to reproduce.

Revision history for this message
AaronL (aaron-n-levinson) wrote :

Created an attachment (id=4)
Screenshot

Revision history for this message
Rusty Lynch (rusty-lynch-intel) wrote :

Have any applications that are currently part of the full-mobile-stack image build expose this bug?

Revision history for this message
AaronL (aaron-n-levinson) wrote :

I'm not sure how it is relevant if any applications that are currently part of the full-mobile-stack image have exposed this bug, but I doubt that it is currently exposed by them. Many of the applications that are part of the full-mobile-stack are not true Hildon applications, not that there are many of them at this point anyway. Besides, it states clearly on the moblin.org Web site that existing Hildon/maemo applications should be easily portable to Intel MIDs.

Revision history for this message
Horace (horace-li) wrote :

This is caused by lacking of hildon-libs-l10n-engb || hildon-libs-l10n-english package, hildon-libs has its translation table for each hildon widget, and if translation table is not found, it will show up the text id directly, which is the text displayed in this bug.

Revision history for this message
Horace (horace-li) wrote :

we are trying to put hildon-libs-l10n into our release, once it is done, this bug could be fixed.

Changed in moblin-ui-framework:
status: Triaged → Confirmed
Revision history for this message
yanglei (lei-a-yang) wrote :

I tested after install hildon-libs-l10n-engb, hildon-libs-l10n-mr, hildon-libs-l10n-english and restart the hildon desktop. I just found the symptom is still there. please see the screen-short.

Also, I tested on CB and Samsung Q1U with latest image. The results are same.

please see the screen short

Revision history for this message
yanglei (lei-a-yang) wrote :

I installed hildon-libs-l10n-english and hildon-libs-l10n-engb in the latest image.
This time the symptoms fixed.

I think in above comments, there may be some pacakges missed when verifying.

The hildon-libs-l10n* pacakges are not included in images defaultly yet.

Revision history for this message
Bob Spencer (bob-spencer) wrote : RE: [Bug 146102] Re: HildonGetPasswordDialog dialogs do not displayproperly

Aaron,
Sorry to bug again... This is the bug I'm trying to close.
Bob

yanglei wrote:
> I tested after install hildon-libs-l10n-engb, hildon-libs-l10n-mr,
> hildon-libs-l10n-english and restart the hildon desktop. I just found
> the symptom is still there. please see the screen-short.
>
> Also, I tested on CB and Samsung Q1U with latest image. The results
> are same.
>
> please see the screen short
>
> ** Attachment added: "screen-shot-for-hildon-get-password-dlg"
>
>
http://launchpadlibrarian.net/10477145/C%3A%5CDocuments%20and%20Settings
%5Clyang12%5CDesktop%5CHildonGetPasswordDialog.PNG

Revision history for this message
yanglei (lei-a-yang) wrote : RE: [Bug 146102] Re: HildonGetPasswordDialog dialogs do notdisplayproperly

Bob,

Sorry. The environment I tested yesterday has some different with latest one.
So I did not verify the bug-fix.
It is OK if apply Horace's method to resolve the issue.

I think we need add hildon-libs-l10n packages in default fset and we can verify the bug in default release image.

Thanks and Best Regards
Lei Yang
-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Bob Spencer
Sent: 2007年11月21日 1:27
To: Yang, Lei A
Subject: RE: [Bug 146102] Re: HildonGetPasswordDialog dialogs do notdisplayproperly

Aaron,
Sorry to bug again... This is the bug I'm trying to close.
Bob

yanglei wrote:
> I tested after install hildon-libs-l10n-engb, hildon-libs-l10n-mr,
> hildon-libs-l10n-english and restart the hildon desktop. I just found
> the symptom is still there. please see the screen-short.
>
> Also, I tested on CB and Samsung Q1U with latest image. The results
> are same.
>
> please see the screen short
>
> ** Attachment added: "screen-shot-for-hildon-get-password-dlg"
>
>
http://launchpadlibrarian.net/10477145/C%3A%5CDocuments%20and%20Settings
%5Clyang12%5CDesktop%5CHildonGetPasswordDialog.PNG

--
HildonGetPasswordDialog dialogs do not display properly
https://bugs.launchpad.net/bugs/146102
You received this bug notification because you are a direct subscriber
of the bug.

Revision history for this message
Bob Spencer (bob-spencer) wrote : RE: [Bug 146102] Re: HildonGetPasswordDialog dialogs donotdisplayproperly

Loic,
I have recently added hildon-libs-l10n-engb to the moblin gaston repository and also to the "Ubuntu-staging" fset. FYI, this fset was created as a holding place for components currently in moblin that we want to include in Ubuntu, but haven't got there yet. Of course you should verify with us that the packages are ready before pulling.

Let me know if you have questions. This package would go into Hardy and also Gutsy PPA and be included as part of the Ubuntu hildon metapackage. When it is, and we've updated MIC to pull from one of these places, then I'll remove this from the Ubuntu-staging fset.

Now... this package brings up the question of I18N in general for hildon-desktop. I saw another thread with KyleN about that.

Bob

yanglei wrote:
> Bob,
>
> Sorry. The environment I tested yesterday has some different with
> latest one.
> So I did not verify the bug-fix.
> It is OK if apply Horace's method to resolve the issue.
>
> I think we need add hildon-libs-l10n packages in default fset and we
> can verify the bug in default release image.
>
> Thanks and Best Regards
> Lei Yang
> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf
> Of Bob Spencer
> Sent: 2007年11月21日 1:27
> To: Yang, Lei A
> Subject: RE: [Bug 146102] Re: HildonGetPasswordDialog dialogs do
> notdisplayproperly
>
> Aaron,
> Sorry to bug again... This is the bug I'm trying to close.
> Bob
>
> yanglei wrote:
>> I tested after install hildon-libs-l10n-engb, hildon-libs-l10n-mr,
>> hildon-libs-l10n-english and restart the hildon desktop. I just found
>> the symptom is still there. please see the screen-short.
>>
>> Also, I tested on CB and Samsung Q1U with latest image. The results
>> are same.
>>
>> please see the screen short
>>
>> ** Attachment added: "screen-shot-for-hildon-get-password-dlg"
>>
>>
> http://launchpadlibrarian.net/10477145/C%3A%5CDocuments%20and%20Settings
> %5Clyang12%5CDesktop%5CHildonGetPasswordDialog.PNG
>
> --
> HildonGetPasswordDialog dialogs do not display properly
> https://bugs.launchpad.net/bugs/146102
> You received this bug notification because you are a direct
> subscriber of the bug.

Revision history for this message
Bob Spencer (bob-spencer) wrote :

hildon-libs-l10n-engb has been added to the Ubuntu-Staging fset. That means that you have to install the "full-moble-stack" fset and then the "ubuntu-staging" fset for this to work.
  I requested this package to be included in the Hardy and Gutsy PPA Ubuntu repositories. When it is we can release it from Ubuntu-Staging.

Changed in moblin-ui-framework:
status: Confirmed → Fix Committed
Revision history for this message
yanglei (lei-a-yang) wrote :

verified in QA image (2007-11-28)

Changed in moblin-ui-framework:
status: Fix Committed → Fix Released
cathyli (cathy-li)
Changed in moblin-ui-framework:
milestone: none → m8
Revision history for this message
AaronL (aaron-n-levinson) wrote :

For mccaslin-lpia targets, the package has been added to both the ubuntu-mobile and ubuntu-staging fsets. However, for menlow-lpia, it has only been added to the ubuntu-staging fset. It seems that if the package has been added to ubuntu-moblin for mccaslin-lpia, which is typically installed by default, unlike ubuntu-staging, then it should be possible to add it to ubuntu-mobile for menlow-lpia and remove it from ubuntu-staging for both menlow-lpia and mccaslin-lpia.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.