Video corruption in midbrowser, Firefox

Bug #264485 reported by Steve Magoun
Affects Status Importance Assigned to Milestone
Moblin (other)
Ubuntu Mobile Edition
Fix Released

Bug Description

Certain websites exhibit video corruption when the xserver-xorg-vidoe-psb driver is in use.

To reproduce:
1) In Ubuntu Mobile, launch midbrowser and navigate to . There will be a brown vertical stripe that runs through the page. The stripe should not be there.
2) Scroll down to the bottom of the page, then scroll back up to the top. Notice the page background now has very bad banding. The banding should not be there.

Refreshing the page will eliminate the banding, but not the stripe.

The problem is not reproducible on the same hardware/software platform using the vesa driver; I can only reproduce with the -psb driver.

I've noticed the problem at 800x600, 1024x768, and 1280x800. I haven't tried other resolutions. The problem is reproducible on Crown Beach and other menlow-based hardware, with both VGA (CRT) and LCD displays attached.

Revision history for this message
Steve Magoun (smagoun) wrote :

I just reproduced this using the "Menlow Install Image" of UME 8.04.1:

Reproduced on a D1 Crown Beach with BIOS PSD1C073. The CB was hooked up to a 15" VGA CRT running at 1024x768. I am using a USB mouse w/ scroll wheel; I used the mouse wheel to scroll down then up to create the banding.

The steps to reproduce remain the same as originally reported - navigate to using midbrowser.

See attached screenshot for an example of the banding and the brown vertical stripe.

Revision history for this message
Steve Magoun (smagoun) wrote :

Gfx driver version in UME is xserver-xorg-video-psb 0.15.0-0ubuntu1~804um2, which corresponds to I noticed that UME 8.04.1 reports libdrm

I do not think the version mismatch in UME 8.04.1 is the problem, we have also reproduced the problem on another Menlow system running the psb driver and libdrm from

The problem affects devices using the Phoenix BIOS in addition to the AMI BIOS on the CB.

Revision history for this message
CheonwoeiNg (cheon-woei-ng) wrote :

Information found so far:

1. If we test on images download directly from Canonical, like 8.04.1 with Gfx 19 and 8.04.1a with Gfx 19, we see this issue.

2. If we take the 8.04 PV build, then manually using dpk to upgrade the driver to Gfx 19, we see NO issue.

3. If we take the 8.04.1a build, then manually using dpkg to upgrade the driver to Gfx 20, we see NO issue.

Per tester:

The problem module is xserver-xorg-video-psb. It is supposed to overwrites /usr/lib/xorg/modules/ from xserver-xorg-core.

When perform –-force-overwrite xserver-xorg-video-psb over the other module and reboot, the problem goes away.

This sounds like a Canonical build script is ignoring the conflict and is not replacing the file as it should.

Revision history for this message
Loïc Minier (lool) wrote :

I checked our xserver-xorg-video-psb package, and it doesn't install the exa fork which lives in this source; instead we rely on the Ubuntu exa module (as all other drivers).

I tried installing this exa module in our packages as exa-psb, but I couldn't get the Xorg server to load it. If I replace the official exa module with the exa-psb one I built, I don't see the gray bar anymore.

Revision history for this message
Loïc Minier (lool) wrote :

I also diffed the exa changes to see whether they would make sense in Ubuntu's xserver-xorg, but I wasn't confident enough to do so without a changelog or rationale for each change.

Revision history for this message
Loïc Minier (lool) wrote :

Steve, I've pushed xserver-xorg-video-psb 0.15.0-0ubuntu1~804um4 to the ubuntu-mobile ppa, it fixes the midbrowser display glitch for me.

I'm not sure it's suitable for Ubuntu intrepid though as installing the psb driver's exa version might break all other drivers.

Changed in ubuntu-mobile:
status: New → Fix Committed
Revision history for this message
Steve Magoun (smagoun) wrote :

xserver-xorg-video-psb 0.15.0-0ubuntu1~804um4 fixes the Firefox/midbrowser display glitch for me too.

Loïc Minier (lool)
Changed in ubuntu-mobile:
status: Fix Committed → Fix Released
dino99 (9d9)
Changed in moblin-other:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.