Native Helix MPEG2 splitter can't connect to CIP AC3 audio

Bug #198988 reported by Jessica Ji
Affects Status Importance Assigned to Milestone
Moblin Multimedia

Bug Description

Bug detailed descriptions:

Native Helix MPEG2 splitter doesn't produce audio mime type for AC3.

Reproduce steps:

1. Install Moblin: and
atlas/lpia/helix-dbus-server_0.242-beta2_lpia.deb .

2. Copy MPEG2 video decoder and AC3 audio decoder from
ww05 engineering drop to /usr/lib/helix/splay

3. Download B-V-MPEG_PS_NTSC-AC3-8.mpg from ftp://xwu2-

4. Run "./splay ~/tv/tiny-test-set/B-V-MPEG_PS_NTSC-AC3-8.mpg"

Current result:

No audio played:

# ./splay ~/tv/tiny-test-set/B-V-MPEG_PS_NTSC-AC3-8.mpg
Simpleplayer is looking for the client core at /usr/lib/helix/splay//
opening file:///root/tv/tiny-test-set/B-V-MPEG_PS_NTSC-AC3-8.mpg on player 0
----------------clip info--------------------
libva: VA_DRIGetClientDriverName: 0.1.0 psb (screen 0)
libva: va_getDriverName() returns 0
libva: Trying to open /usr/X11R6/lib/modules/dri/
libva: va_openDriver() returns 0
========Source 0========
====File Header====
StreamCount 1
DefaultLicenseValue 0
FileType MPEG2
LicenseKey license.Summary.Datatypes.RealMPEG2.Enabled
====Stream 0====
StreamNumber 0
AvgBitRate 3259896
MaxBitRate 4237864
Preroll 1500
Duration 122148
StartTime 0
MaxPacketSize 4096
AvgPacketSize 2048
Width 720
Height 480
TrackEndTime 122148
PostDecodeDelay 400
Resumed 1
FrameWidth 720
FrameHeight 480
MimeType video/vnd.rn-mp2p
ASMRuleBook AverageBandwidth=3259896, AverageBandwidthStd=0, Priority=9;

Expected result:

Playback similar to if you add CIP splitter plugin ipp_hx_mp2sp and remove native Helix

Basic root-causing log:

------- Additional Comment #1 From Zhao, Aihua 2008-02-20 18:35 -------
      this bug is invalid because you should install helix-cip-codecs debian
pacakge to use CIP codecs.
      Besides helix-dbus-server debian package, we also have a helix-cip-codecs
debian package for CIP codecs.
      And in the helix-cip-codecs debian package’s install/uninstall scripts, it
will deal with such conflict issues to update and
      So these are invalid bug for Moblin

      you'd better contact to the person who give you the moblin image for where
is corresponding helix-cip-codecs debian package.

------- Additional Comment #2 From Dmitry Rogozhkin 2008-02-20 21:22 -------
I installed next packages:

dpkg -i helix-dbus-server_0.26-beta3_lpia.deb
dpkg -i helix-cip-codecs_0.26-beta3_lpia.deb

After this I tried to use "" which I found in /usr/lib/helix/splay/for_cip_bak instead of CIP mpeg2 splitter plugin:
cd /usr/lib/helix/splay/
mkdir cip_bak
mv ./cip_bak/
mv ./for_cip_bak/ ./

I played with 'splay' application file containing AC3 audio B-V-MPEG_PS_NTSC-AC3-8.mpg.
But this playback was without AC3 audio. Video playback was good.
Such situation may happen only if no AC3 audio was detected by "" plugin at all. If some audio was detected, then splay would print corresponding
mime type (audio/vnd.rn-mp2pAC3). I didn't see it.

So, currently mpgfformat provided by OTC doesn't support AC3 audio. I know, that AC3 should be specially enabled and recompilation of mpgfformat plugin is

I reopen this bug because it is not fixed and I increase it severity.

------- Additional Comment #3 From Zhao, Aihua 2008-03-03 15:33 -------
the release pacakge of beta3 could playback the content correctly.
so this is invalid bug for beta3.

------- Additional Comment #4 From May Xie 2008-03-05 08:58 -------
Could bug reporter to reproduce the issue on helix beta3 packages and update
the status here? If this cannot be reproduced, pls. verify this bug. Thanks.

------- Additional Comment #5 From Dmitry Rogozhkin 2008-03-05 17:20 -------
1. Current situation with this issue.
This issue was found in Beta3 package I downloaded ~20 of February (I don't remember exactly).
This issue is _fixed_ in Beta3 package I downloaded at 03 March 2008.

I am fully disagree that this bug is invalid. I saw this bug, now it is fixed. Why it is invalid? In this case I can't understand what I
should verify.
Please, reopen this bug, mark this bug as fixed and when I will mark it as verified and it can be closed.

That's my opinion about this issue and all future _valid_ issues which (if) will be found.

2. We have changes in CIP SOW.
Only CIP Demuxer will be used for Mpeg2 streams splitting (PS and TS). Helix native Mpeg2 splitter will not be used by CIP.
This will be true in next drop you will receive from us.

But it will be good to have mpgfformat.sp with enabled AC3 support for comparison in possible difficult situations.

------- Additional Comment #6 From Zhao, Aihua 2008-03-05 17:34 -------
the following is dmitry's action, and it isn't the correct way to use the
package. if you want a native mpeg splitter with AC3 enabled for comparison, we
can give you that in next release:
After this I tried to use "" which I found in
/usr/lib/helix/splay/for_cip_bak instead of CIP mpeg2 splitter plugin:
cd /usr/lib/helix/splay/
mkdir cip_bak
mv ./cip_bak/
mv ./for_cip_bak/ ./
We have two version of native helix MPEG-2 splitter.
The version disable AC3 is used for default helix-dbus-server*.deb package, and
it will be removed (copy to for_cip_bak folder) when install
helix-cip-codec*.deb package. And you are reporting something against this
version of native helix mpeg-2 splitter. But this version of native Helix
mpeg-2 splitter has nothing to do with CIP’s codecs.

For the version enable AC3, whether use it or not, how to use it , all depends
on CIP’s request.
In our Beta2 release, we include native mpeg-2 splitter with AC3 enable
following CIP’s release note.
And in our Beta3 release, we don’t include native mpeg-2 splitter with AC3
enable, this also following CIP’s release note.

Revision history for this message
Jessica Ji (jessica-ji) wrote :
Changed in moblin-multimedia:
assignee: nobody → halley-zhao
importance: Undecided → High
Revision history for this message
Halley (halley-zhao) wrote :

our beta2 release has no such issue.
what they copied some libraries is not the correct way to use the package

Changed in moblin-multimedia:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.