Mouse selection not highlighted in win 32 bit builds

Bug #1751482 reported by kek001 on 2018-02-24
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned
2.1
High
Unassigned
2.2
High
Unassigned

Bug Description

Windows 7,32 bit, mixxx feb 20, mixxx release 6506 works, but not newer.

If selecting track wont activate track in libarary window , not activate track colour track column.
etc....

This issue came back it was fixed.

kek001 (kek001) wrote :

I mean it wont activate row, turn background colour orange or ....
and wont drag drop correct tracks.

It loads track to deck. if clicking. thats all.

Be (be.ing) wrote :

Can you attach a screenshot of what happens when you select a track?

kek001 (kek001) wrote :

Hi thank you for response
.
Nothing happedds. can show it using screenshot.

It wont highlight the song row, what use to do.
If I double click it will load track to deck.

if i press keyboard arrow it will highlight the row. but if I try to activate by mouse.

other track/song it wont highlight it and activate it. and i i try now dragdrop song what i click with mouse it will drag and drop song what is highlighted by mouse.

I cant select multiple tracks. and drag and drop to playlist. or analyze, what i could do ealier.

This was fixed in some 2.1 version, but it was overwriten.

regards,

kek001 (kek001) wrote :

I mean I cant's show using screenshot.

Be (be.ing) wrote :

That is quite odd. Do you use any third party theme system for Windows or have you changed the system colors?

kek001 (kek001) wrote :

I use latenight theme just default, and tried other themes, same result.

I dont use any theme application like rainmaker, and all my visual effects are off, except smoothing font edges. I can use other application very well, like ableton live, and ten's other application.
Mixxx 2.0 worked fine. before installing 2.1

My windows 7,32 theme is just plain black, without any effects.

Yes its odd, an there are at least one other person in bug report who experience same. and saw in forum.

I have tried to figure out what is it, but no bright light in bulb.
I have experience of programming long time, and fighting with comps. I mean not just typical end user.
whose mouse is doing tricks,

I havent chaned system colours, it just dont activate the row and highlight it, and change active track, it activate tracks and highlights them if i am pressing arrow keys.
and it load track to deck if i double click.

I am using just standard logitech plain simple mouse, which is not special game mouse or...

kek001 (kek001) wrote :

In "library" section where are tracks if i click song/track with mouse it will draw thin cut line the table "cell" what i clicked, but wont make row orange,
but if i am pressing arrow key up or down then it will make

and cant drag and drop the song what i pick by mouse.

Be (be.ing) wrote :

I just tried installing mixxx-2.1.0-rc1-2.1-git6663-release-x64.exe on Windows 7 and could not reproduce this.

Be (be.ing) wrote :

Looking through the Git history, I don't see anything between build 6506 on February 19 and build 6505 on February 10 that seems related to this. kek001, are you able to compile Mixxx on Windows? If so, doing a Git bisect could help. Build instructions are at https://mixxx.org/wiki/doku.php/compiling_on_windows

kek001 (kek001) wrote :

The version number can be wrong, i have installed/uninstalled so many version, and because there is latest install file and then named by release number, and i have seen several times, some realease numbers not match what is in "about" or properties.

I dont know if i can compile, i dont have currently any enviroment installed in my machine.

the link is giving bad gateway error.

kek001 (kek001) wrote :

I think someone fixed drag drop issue and it started working, cant remember what realease.
because never reported or message sent to me.

kek001 (kek001) wrote :

https://bugs.launchpad.net/mixxx/+bug/1741800

some version worked 2018-01-28:, i think its deleted from file server where are releases for public.

kek001 (kek001) wrote :

The bug is mixxx dont change/update internal "cursor" row value and not activate highlight and highlight the row what is pressed by mouse, it only calls or receive event which draw cut-line around clicked cell but not call highlight function or rise flag for event or method. and update current row value.

i mean highlight as orange or blue baground row.

soryy no idea how its programmed. thats why i not wrote clearly.

regards,

I saw this on my friend's computer with Windows 8 running Mixxx 2.1. As described in comment #3, the highlight is shown after pressing an arrow key.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
summary: - Selecting tracks by mouse not work
+ Selected tracks not highlighted in library table on older Windows
Changed in mixxx:
milestone: none → 2.1.1
kek001 (kek001) wrote :

Be Thanks for having time for this problem.

The problem is bigger than, highlight row.

If I try to drag and drop song to playlist, it wont drag, or it drag song which is highlighted by arrow key, not a song what i am pointing using mouse and trying to dragdrop.
regards,

Changed in mixxx:
milestone: 2.1.1 → 2.1.2
Be (be.ing) wrote :

Unfortunately it doesn't seem anyone has an idea why this bug is happening, why it happens with some builds but not others, or why it seems to happen for some Windows users but not others. If anyone has done testing to figure out how to reliably reproduce this bug and when it does not appear, please share. Without that information it is hard for any developer to have an idea where to start looking in the code.

Maybe by luck the bug is fixed with Qt5. Recent builds of the master Git branch are using Qt5 now: http://downloads.mixxx.org/builds/master/release/

Daniel Schürmann (daschuer) wrote :

I remove this from the a milestone until we have more info.

Changed in mixxx:
milestone: 2.1.2 → none
kek001 (kek001) wrote :

What you mean more info ?
Do you want video where i show this problem.

If I click by mouse track in library window, it wont highlight/select the track.

Daniel Schürmann (daschuer) wrote :

I can confirm the issue with Mixxx 2.1.2 release version on Windows XP 32 bit but also with 2.1.0-beta1 r60506.

As a workaround I can click on the preview column to select the track.

Wired, I can also reproduce it with the first Mixxx 2.1.2 R6461

Mixxx 2.0 is not effected.

Can you verify again that this an issue in:
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.0-beta1-2.1-git6508-release-x86.exe

And solved in
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.0-beta1-2.1-git6506-release-x86.exe

Changed in mixxx:
importance: Low → High
Daniel Schürmann (daschuer) wrote :

I cannot test QT5 builds on my WinXP machine. Can you do it and test also:
http://downloads.mixxx.org/builds/master/release/mixxx-2.2.0-alpha-pre-master-git6547-release-x86.exe

kek001 (kek001) wrote :

I can confirm, Official Download link from mixxx website is working, do activate and highlight columns/tracks by clicking mouse.

which makes me think is there some build/version issues.

I can try to test mixxx-2.2.0-alpha-pre-master-git6547-release-x86.exe

kek001 (kek001) wrote :

2.2.0 alpha-pre, same problem, wont highlight and activate column/track.

Daniel Schürmann (daschuer) wrote :

Please post the working link here just to be sure. The thing is I cannot confirm it. Everything is broken > 2.0

Please double check also the
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.0-beta1-2.1-git6508-release-x86.exe

And
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.0-beta1-2.1-git6506-release-x86.exe

Both are suffering the issue. Maybe it is an installer issue?

Daniel Schürmann (daschuer) wrote :

It turns out that all Jenkins 2.1 x86 builds suffer the bug but not the AppVeyor build.
Should we replace our own build with teh AppVeyor builds for downloads?

Does anyone have an idea what could be the issue?
This buid works for me:
https://ci.appveyor.com/api/buildjobs/7hihodb61akkm6l7/artifacts/mixxx-2.1.3-2.1-PR1790-git6764-release-x86.exe

@kek001 Can you confirm this?

Sébastien BLAISOT (sblaisot) wrote :

Appveyor start from a fresh build tree each time. Jenkins keeps the build tree between jobs so if something went wrong once, it can stay forever.
we need to empty the Jenkins build workspace for 2.1 and try building a new version Tu see if it's better.
if not better, we need to check Jenkins build env.

Be (be.ing) wrote :

I manually cleared the Jenkins workspace and triggered a new build. Please test:
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.3-2.1-git6763-release-x64.exe
If this works, let's change Jenkins to clear the workspace after each build and increase the version number to 2.1.4.

Daniel Schürmann (daschuer) wrote :

I can confirm that the issue is fixed with todays:
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.3-2.1-git6763-release-x68.exe

Unfortunately just rebuilding the release version without a has deleted our original release version. I think it is required to restore it for reference.
Can we copy the original release version back http://downloads.mixxx.org/builds/2.1/release folder?

Who has write access to this folder and can do this?

I have just bumped the version to 2.1.4-pre to avoid this issue again.

@kek001
please confirm that if the issue is gone with:
http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.3-2.1-git6763-release-x68.exe
from today. Make sure you delete all copies with the same name from your HD before downloading.

Be (be.ing) wrote :

Sorry, I did not realize that manually triggering a build without changing the code would overwrite the file in http://downloads.mixxx.org/builds/2.1/release

The official 2.1.3 binaries are still available at http://downloads.mixxx.org/mixxx-2.1.3/

Daniel Schürmann (daschuer) wrote :

Hi kek001

Please try this build:

http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.4-pre-2.1-git6764-release-x86.exe

Does it solve your issue? If yes, we can release it.

kek001 (kek001) wrote :
kek001 (kek001) wrote :

post #27 version not availaible, 404 not found.

kek001 (kek001) wrote :

i found version maybe same as post#27 dated 25 august. was not found 404 html error.

this version works, with same release version information but location different than post 27#

http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.3-2.1-git6763-release-x86.exe

AND YES YES I CAN CONFIRM IT WORKS.

kek001 (kek001) wrote :

Now my world rocks, i dont like traktor or serato. there are some minor things which doesent bother. i can live with them.

Be (be.ing) wrote :

Before we officially release 2.1.4, kek001, could you confirm that http://downloads.mixxx.org/builds/2.1/release/mixxx-2.1.4-2.1-git6765-release-x86.exe works?

RJ Skerry-Ryan (rryan) wrote :

I'm confused about the workaround to clear the workspace, because I thought the Git configuration was already set to clean the workspace before build? Or did you add that too Be?

Be (be.ing) wrote :

I recently enabled the option to clear the Jenkins workspace before each build when I posted comment #29. Before that, the option was not enabled.

Changed in mixxx:
milestone: none → 2.1.4
Changed in mixxx:
status: Confirmed → Fix Released
RJ Skerry-Ryan (rryan) wrote :

@Be -- yea, but now there are two different options that effectively clear the workspace -- under git there's the option "clean after checkout" which does the following:

Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10

So all untracked files should be wiped out.

I thought this was already enabled, so I'm confused why enabling the "clear the workspace" option in addition to this has any effect.

Be (be.ing) wrote :

The options in the Jenkins configuration that I enabled is the "Delete workspace before build starts" checkbox in the Build Environment section.

Be (be.ing) wrote :

Great, thanks for confirming.

kek001 (kek001) wrote :

2.1.15 windows 7,32bit

the problem came back.

2.1.14 working

kek001 (kek001) wrote :

I mean 2.1.5

RJ Skerry-Ryan (rryan) wrote :

The highlight bug is present for me on Windows 7 64-bit with Mixxx 2.2 beta r6600 using a Jenkins-produced 32-bit build.

RJ Skerry-Ryan (rryan) wrote :

Though, I don't have the issues with drag and drop that you are seeing kek001 -- on Mixxx 2.1.5 or 2.2.0 beta. if I drag a track (unhighlighted) with my mouse into a deck then it loads the correct one, not the currently highlighted track.

RJ Skerry-Ryan (rryan) wrote :

Actually, no I'm wrong -- I do have the drag-and-drop issues.

RJ Skerry-Ryan (rryan) wrote :

Mixxx 2.2 beta r6600 using a Jenkins-produced 64-bit build doesn't have the issue for me on Windows 7 64-bit.

RJ Skerry-Ryan (rryan) on 2018-11-04
Changed in mixxx:
status: Fix Released → Triaged
milestone: 2.1.4 → none
kek001 (kek001) wrote :

 the Problem is also version mixxx-2.1.6-pre-2.1-release-x86-latest

latest working version is 2.1.4

Daniel Schürmann (daschuer) wrote :

I can confirm this with the 32 bit version 2.1.4 works, 2.1.5 not.

Did we clear the workspace before the 2.1.5 build?

geozubuntu (geozubuntu) wrote :

Hello All ..

I faced this bug multiple times from version 1.11 Only in windows. Never in Linux. I run both systems. I have win7 Ultimate x86 fully updated and Linux mint several versions.
Bug comes and goes in alpha-pre git revisions. All times when I faced this I managed to overcome by installing the same git revision downloaded from http://downloads.mixxx.org/builds/appveyor/ instead of http://downloads.mixxx.org/builds/master/release/... after some new alpha pre releases the problem disappeared for some time.. then appeared again and I downloaded the same revision from appveyor directory, and so on.

Last time it showed up to me was git mixxx-2.2.0-alpha-pre-master-git6546-release-x86 which didn't run from master/release dir but did run from /appveyor dir.

I hope this helps. I am not a programmer so I don't know what is the difference between the installers of /appveyor and master/release but I am a technician and I can tell that something in building makes this bug appear. It is minor problem but It is frustrating to reinstall and have to check the database each time and can't select tracks.

Thanks

RJ Skerry-Ryan (rryan) wrote :

Bug is not present for me in 2.2 r6638 64-bit or 32-bit on Windows 7 64-bit.

Daniel Schürmann (daschuer) wrote :

Win10 64 Mixxx 2.1.5 64 OK
Win10 64 Mixxx 2.1.6 64 git6808 64 OK
Win10 64 Mixxx 2.2.0 64 OK
Win10 64 Mixxx 2.1.5 32 Effected
WinXP 32 Mixxx 2.1.5 32 Effected
Win10 64 Mixxx 2.1.6 git6808 32 Effected
Win10 64 Mixxx 2.2.0 32 Effected

summary: - Selected tracks not highlighted in library table on older Windows
+ Mouse selection not highlighted in win bit builds
tags: added: windows
summary: - Mouse selection not highlighted in win bit builds
+ Mouse selection not highlighted in win 32 bit builds
no longer affects: mixxx/2.1
Daniel Schürmann (daschuer) wrote :

2.1.8 (build 2.1 r6828) 32 OK

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers