Tooltips cut off sometimes

Bug #712718 reported by jus on 2011-02-03
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
jus
1.10
Low
jus
1.9
Low
jus

Bug Description

Tested Mixxx 1.9beta1 in Windows 7 for the first time and noticed that the tooltips are cut off sometimes.
It looks to me that the padding which falls between the border and the actual contents of the tooltips is ignored.

Anyone with same problem on Windows/Linux?
On MacOS it looks fine...

Related branches

jus (jus) wrote :
description: updated

I don't think I've noticed that on Linux, but I was just able to confirm
that it's a problem on Vista.

On Thu, Feb 3, 2011 at 12:07 PM, jus <email address hidden> wrote:

>
> ** Attachment added: "example.png"
>
> https://bugs.launchpad.net/bugs/712718/+attachment/1827918/+files/example.png
>
> ** Description changed:
>
> - Tested Mixxx 1.9beta1 in Windows 7 for the first time and noticed that
> the tooltips are cut of sometimes.
> + Tested Mixxx 1.9beta1 in Windows 7 for the first time and noticed that
> the tooltips are cut off sometimes.
> It looks to me that the padding which falls between the border and the
> actual contents of the tooltips is ignored.
>
> - Anyone with same problem on Windows/Linux?
> + Anyone with same problem on Windows/Linux?
> On MacOS it looks fine...
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/712718
>
> Title:
> Tooltips cut off sometimes
>

RJ Skerry-Ryan (rryan) on 2011-03-07
Changed in mixxx:
status: New → Confirmed
Qifan Xi (khyew) wrote :

Confirmed problem in Windows XP

RJ Skerry-Ryan (rryan) wrote :

I suspect it's a Qt bug.. we don't do anything that outlandish, and our verbatim code appears in some Qt documentation examples.

jus (jus) wrote :

Also think it is a QT bug,I came across a very similar one in qt bug tracker but i cant`t find it now between the myriad of tooltip related bugs. There is another similar issue reported: http://bugreports.qt.nokia.com/browse/QTBUG-1861

Have tried to solve this problem by trial & error as i can not really reproduce the behavior (seems random). The only way it worked out pretty good was to scrap the tool tip styling and display the default (yellow) style. Do we want that?

RJ Skerry-Ryan (rryan) on 2011-10-05
Changed in mixxx:
importance: Undecided → Low
toomuch (toomuch) wrote :

Same here on Win7 x64. Every tooltip is cut off on 1.10.0beta1.

RJ Skerry-Ryan (rryan) wrote :

If the problem is this broad (every tooltip) then it's worth trying to pin down for 1.10.0

RJ Skerry-Ryan (rryan) wrote :

I've got no clue.. marking triaged and moving to 1.10.1.

Changed in mixxx:
status: Confirmed → Triaged
jus (jus) wrote :

This is a QT bug obviously with QTooltip that uses stylesheets:
* Changing the font size for Tooltips does not display correctly on Windows
   https://bugreports.qt.nokia.com/browse/QTBUG-4342
* Padding in QToolTip stylesheet causes text to show incorrectly
   https://bugreports.qt.nokia.com/browse/QTBUG-20027
* QToolTip box doesn't resize properly with larger font
   https://bugreports.qt.nokia.com/browse/QTBUG-7874

Will try to work around that issues again, if nothing else works we still could go back to the default tooltips like said in #5

Changed in mixxx:
assignee: nobody → jus (jus)
jus (jus) wrote :

Potential fix in lp:/mixxx/1.10
Worked around the issue by removing the custom font size declarations and padding , using systems default. At least it seems we still can use custom colors. Tested working on Win 7.

PS.
It would be awesome if we could have one declaration for the Qtooltip style in skin.xml, currently every tooltip needs a declaration for its own.

jus (jus) wrote :
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments