Mixxx 1.8.2 don't play files were the filename contains umlauts

Reported by Wolfgang Winter on 2011-02-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned
1.10
High
Unassigned
1.8
High
Unassigned
1.9
High
Unassigned

Bug Description

Hi,
Files, contains "umlauts" in the filename can't be imported.

Somone know about this error?
I'v compiled the version of mixxx 1 month ago.. so i think it's a newer one of 1.8.2.

Mixxx 1.8.2
ArchLinux 64

Some more:
There are mp3 files, after rename (without umlauts, they can be imported.

RJ Ryan (rryan) wrote :

Thanks Wolfgang,

We'll take a look.

RJ Ryan

RJ Ryan (rryan) wrote :

Wolfgang,

Just to check -- how are you importing the files? Are you using the RhythmBox feature? Is the file in your Music directory and Mixxx is scanning it via the library scanner? Are you drag+dropping the file into Mixxx?

Thanks,
RJ

Hi RJ,
i don't use the rhytmbox feature (here the error exits, i know), i import from a ext4 filesystem, the music is in an directory "musik".

I'm a bit confused, because i think, at an earlier installation the error doesn't exist ....but i dont't know it for shure. This time i arrange my songs for an dj evening in april and i missed some songs, they all contains umlauts "über den wolken" for example.
Sometimes drop them, mostly i use the menu (left click). The problem isn't that the song can't be load,the problem is, that it don't exist in library after scanning (the ryhtmbox error: song exists in library but i can
t load).
After rename the song and re-scan library, i can see the song with its Umlauts in mp3 tags.

Thank you
Wolfgang

The problem with umlauts still exists in Version 1.9.0:

Hi,
the problem still exists in Mixxx 1.9.0:

Tim Toupet - So ein schöner Tag (Fliegerlied).mp3

Tim Toupet - So ein sch?ner Tag (Fliegerlied).mp3

isn't after scan in the library, a third version:

Tim Toupet - So ein schoener Tag (Fliegerlied).mp3
 can be found in the library after scanning.

So filenames with special characters and umlauts can't be scanned?

RJ Ryan (rryan) wrote :

thanks Wolfgang, I'll take a look this weekend.

Bill Good (bkgood) wrote :

I've tried reproducing this with the Tim Toupet filename and was able to get the scanner to import it both with a fresh DB and an existing one -- so I'm not sure what's going on here (I also have a file with an e acute in its name in my test library without issue so who knows).

Wolfgang, is there any chance you could attach your Mixxx library database? It's stored at ~/.mixxx/mixxxdb.sqlite.

Here is the directory .mixxx, packed.

Best regards
Wolfgang

Hello,
here a second upload from my other system. Here i've only a smal library / only a few songs from one artist.

The files with umlauts are:

Herbert Grönemeyer Feat. Amadou Mariam Was Muss Muss - Best Of 1 13 Zeit Dass Sich Was Dreht (Deutsche Version) (Feat. Amadou Mariam).mp3
Herbert Grönemeyer feat. Antony Was Muss Muss - Best Of 2 19 Will I Ever Learn (Duett) (feat. Antony).mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 10 Chaos.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 11 Du Bist Die.jpg
Herbert Grönemeyer Was Muss Muss - Best Of 1 11 Du Bist Die.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 12 Land Unter.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 14 Ich Dreh Mich Um Dich.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 15 Die Härte.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 16 Leb In Meiner Welt.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 17 Stück Vom Himmel.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 1 Mensch.jpg
Herbert Grönemeyer Was Muss Muss - Best Of 1 1 Mensch.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 2 Kopf Hoch Tanzen.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 3 Glück.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 4 Fisch Im Netz.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 5 Fanatisch.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 6 Demo (Letzter Tag).mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 7 Zum Meer.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 8 Der Weg.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 1 9 Bleibt Alles Anders.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 10 Komet.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 11 Luxus.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 12 Bochum.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 13 Alkohol.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 14 Marie.jpg
Herbert Grönemeyer Was Muss Muss - Best Of 2 14 Marie.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 15 Total Egal.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 16 Currywurst.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 17 Mambo.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 18 Ich Hab Dich Lieb (Live).mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 1 Was Soll Das.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 2 Männer.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 3 Kinder An Die Macht.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 4 Flugzeuge Im Bauch.jpg
Herbert Grönemeyer Was Muss Muss - Best Of 2 4 Flugzeuge Im Bauch.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 5 Musik Nur Wenn Sie Laut Ist.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 6 Deine Liebe Klebt.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 7 Halt Mich.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 8 Kaufen.mp3
Herbert Grönemeyer Was Muss Muss - Best Of 2 9 Vollmond.mp3

In the directory "Musik" there are other files from the same artist, in the dir "live", this songs can be imported in library.

Bill Good (bkgood) wrote :

Could you post the output of `find ~/Musik` on the Ubuntu system (just because the library is much smaller, easier to work with)?

Thanks!

Hello,
here is the original output of 'find ~/Musik'

Thank you
Wolfgang

RJ Ryan (rryan) wrote :

Hm, I too am pretty stumped here. I've tested in the latest version of the 1.8.x branch as well as the latest version of the 1.9.x branch and I was able to add a track that had umlauts in its filename via the library scanner.

Hi,
what can i do?

I installed mixxx1.9.0 on 2 systems, a Ubuntu 32bit and ArchLinuxOS64bit, on both systems this tracks aren't in library after scan, when i put a file from nautilus or an other linux file manager in mixxx, it can't loaded (message: file does not exist).

Can i send you some test files?

May be the error occurs only by some conditions (filename + file length + ???)

I've by example some tracks named "aprés ski hits 1.mp3", they can't be loaded, too. After rename the word "aprés" to "apres" i can import the track.

May be the error occurs only on a german localized system?

But why?

The filesystem is ext3 / ext4 and for the filesystem the language doesn't matter..

RJ Ryan (rryan) on 2011-10-05
Changed in mixxx:
importance: Undecided → High
status: New → Triaged
tags: added: i18n library
RJ Ryan (rryan) wrote :

I just fixed a problem with our WAV support in the 1.10 branch that prevented files with special characters from loading. That is probably one component of this issue.

jus (jus) wrote :

Bug is gone in the 1.10.0 release - Confirmed by Wolfgang Winter
http://mixxx.org/forums/viewtopic.php?f=3&t=2311#p12683

Changed in mixxx:
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers