win xp reports error on initial library scan

Reported by jnees on 2008-05-29
6
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned
1.6
Undecided
Unassigned

Bug Description

System: Windows XP Professional 2002 SP2
Scan on directory on external USB 2 HD.
Filename displayed in the mix popup: "Future Cut + Futurebound - Homicide.mp3"
tried rescan after the name changed and '+' char removed, crash on the same file, also sometimes immediate crash without displaying the library scan popup.
Mixxx main window is displayed as long as the windows error popup isn't closed.

Albert Santoni (gamegod) wrote :

What version of Mixxx are you using? (Thanks)

Albert Santoni (gamegod) on 2008-06-03
Changed in mixxx:
importance: Undecided → High
status: New → Triaged
Albert Santoni (gamegod) wrote :

Can you upload this file somewhere?
We (urgently) need more information about this problem so we can fix it...

Albert Santoni (gamegod) wrote :

jnees: Can you please run and test this new build?
http://downloads.mixxx.org/mixxx-1.6.0-svn/mixxx-1.6.0-svn06212008-win.exe

Please report if you experience the same bug.

Albert Santoni (gamegod) wrote :

jness: I've uploaded a new build which fixes a problem with OGG files crashing Mixxx's library scan on Windows:
http://downloads.mixxx.org/mixxx-1.6.0-svn/mixxx-1.6.0-svn07202008.exe

Please test this build and let us know if the problem is fixed.

Albert Santoni (gamegod) wrote :

Tentatively marking this as fixed because of recent MP3 and OGG header parsing fixes.

Changed in mixxx:
status: Triaged → Fix Committed

The library scan works fine now.

On Wed, Jul 23, 2008 at 5:48 AM, Albert Santoni <email address hidden> wrote:
> Tentatively marking this as fixed because of recent MP3 and OGG header
> parsing fixes.
>
> ** Changed in: mixxx/1.6
> Status: New => Fix Committed
>
> --
> win xp reports error on initial library scan
> https://bugs.launchpad.net/bugs/235807
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Mixxx: Fix Committed
> Status in Mixxx Series: 1.6: Fix Committed
>
> Bug description:
> System: Windows XP Professional 2002 SP2
> Scan on directory on external USB 2 HD.
> Filename displayed in the mix popup: "Future Cut + Futurebound - Homicide.mp3"
> tried rescan after the name changed and '+' char removed, crash on the same file, also sometimes immediate crash without displaying the library scan popup.
> Mixxx main window is displayed as long as the windows error popup isn't closed.
>

V Paton (vpaton) wrote :

I have the same issue with scanning mp3s on an external USB drive. Using XP sp3 on an Acer laptop. Gets half way through and then crashes.

App works as expected for all other functionality.

I tried the mixxx-1.6.0-svn07202008.exe file, but produced the same result.

Changed in mixxx:
status: Fix Committed → Incomplete
Albert Santoni (gamegod) wrote :

V Patron: You tried the 1.6.0 final release from mixxx.org, right?

V Paton (vpaton) wrote :

Sorry. Yeah, had installed the normal download from Mixxx.org first - the svn was an attempt to fix as it seems to have worked for jnees.

It's actually a Packard Bell laptop (forgot it was on the misses'), not that that's likely to matter.

ironstorm (ironstorm-gmail) wrote :

@V Patron: send us the mixxx.log in %USERPROFILE% or if you know what song file send us that, otherwise we have very little to go on.

V Paton (vpaton) wrote :

as requested

Albert Santoni (gamegod) wrote :

We should try to look at this before 1.6.1...

Changed in mixxx:
status: Incomplete → Triaged
ironstorm (ironstorm-gmail) wrote :

Was it fixed in 1.6.1?

V Paton, if you still experience this problem can you try the snapshot build here: http://mixxx.org/packages/windows/mixxx-SVN2740-20090322_1916-win.exe and run Mixxx via the "Mixxx (inside GNU Debugger)" desktop shortcut and paste the backtrace in this bug (see http://mixxx.org/wiki/doku.php/creating_backtraces from step 3 onward for how to get the bt)

ironstorm (ironstorm-gmail) wrote :

Mixxx 1.7.0 was released on Aug 6, 2009, so this fix would have gone out at that time.

Changed in mixxx:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers