Overview waveform loop & hot cue markers not customizable

Reported by RJ Ryan on 2010-01-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Thomas Vincent
1.10
Medium
RJ Ryan
1.11
Low
Thomas Vincent
1.8
Low
RJ Ryan
1.9
Medium
RJ Ryan

Bug Description

- The waveform overview shows loop markers, but the colors are not customizable via skin.
- The cue point is not shown on the overview waveform, while hot cues are.
- Hot cue markers in overview waveform need to be customizable (or at least thin lines matching the skin hot cue color instead of large digits)

RJ Ryan (rryan) on 2010-01-13
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
milestone: none → 1.8.0
importance: Undecided → Low
status: New → Confirmed
RJ Ryan (rryan) wrote :

We're going to have to handle this in 1.8.1 unfortunately.

Changed in mixxx:
milestone: 1.8.0 → 1.8.1
Changed in mixxx:
milestone: 1.8.1 → none
description: updated
summary: - Waveform Overview Loop Markers Not Customizable
+ Overview waveform loop & hot cue markers not customizable
description: updated
RJ Ryan (rryan) wrote :

Making this one of my priorities for 1.9.0. Could use feedback from Jus on how this would work ideally.

RJ Ryan (rryan) on 2010-11-04
tags: added: waveform
Thomas Vincent (vrince) wrote :

I'll try to implement it in waveform-2.0

Thomas Vincent (vrince) wrote :

Ok little feedback here a creen shot of what customisable cue and hot-cue looks like in the branch.

I'll probably need some help to update all skins. cause now hot-cues need to be explicitly declared in each <Overview> to be connected and displayed.

Any volunteer ? It's realy simple but need to be tested againt all the skins ...

jus (jus) wrote :

Hi Thomas, thanks for tackling this too.
You really do not have to update all the skins, your demo in LateNight1280x800-WXGA is a good enough. The skins are subject to significant change once we have the 1.11 feature freeze and all the features are merged into trunk.

Some comments on the changes to the waveform overview.:
* Hotcues >4 are not displayed. Is this intentional? We allow up to 36 hotcues per deck ( and they are displayed at the main waveform) even if we have only 4 of them visible in the GUI per default.
* Can`t use <Pixmap> to declare custom graphics for Loop/Cue marker just like we can for the main waveform ( as seen in the Deere skin). No biggie, would be nice to have though.

Cosmetically:
* At the main waveform all the markers are draws behind the waveform , they should be on top. It`s fine on the waveform overview.
* At the main waveform the loop overlay is drawn behind the waveform while is drawn on top of the waveform overview.
* Loop overlay at the main waveform has different alpha then at the waveform overview , the latter has better visibility imo.

Thomas Vincent (vrince) wrote :

For full hot-cues support, we just need to add all hot-cues in skins.
The render stack orders (mark/loop/signal) should be fixed by now.
I'll see if I can quickly add loop alpha customization. Cause I guess any value I can choose will be wrong at some point depending skin designer color choices :).

Thanks for all those feed-backs it make every changes I make a lot more useful !

RJ Ryan (rryan) wrote :

This code is now in trunk... thanks for fixing this one Tom :)

Changed in mixxx:
status: Confirmed → Fix Committed
assignee: RJ Ryan (rryan) → Thomas Vincent (vrince)
RJ Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers