Analyze doesn't show new tracks

Reported by Till Hofmann on 2011-04-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann
1.10
Medium
Unassigned
1.11
Medium
Daniel Schürmann
1.9
Medium
Unassigned

Bug Description

Steps:
1. Add a track to the library (e.g. by rescanning)
2. Go to the Analyze view
The new tracks are not shown.
If you change the view to "All Songs" from "Recently Added" or vice versa, the new track appears.

Mixxx trunk Revision #2758

alex marin (alex-marin89) wrote :

If you run on windows 7 and add tracks to the library (step1) and then go to analyze view (step2) the new tracks are not shown, even if you change the view to "All Songs" from "Recently Added" or vice versa. The only way you are able to see them is by restarting Mixxx. On Ubuntu 10.10, the behavior is as in the description ( the new tracks appear if you change the view, no need for restarting).

RJ Ryan (rryan) wrote :

We should check that this is fixed.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 1.10.0
RJ Ryan (rryan) wrote :

It's not fixed yet.

Changed in mixxx:
milestone: 1.10.0 → none
RJ Ryan (rryan) on 2011-10-13
tags: added: analyze library
Daniel Schürmann (daschuer) wrote :

With the current trunk lp:mixxx #2950 new songs are displayed when you switch between "all" and "recent" tracks or if you resort via header click.

Daniel Schürmann (daschuer) wrote :

All changed and new tracks where signalled by BaseTrackCache.
One solution would be to do select, if a new track is signalled. This is a good Idea for currently not displayed tables, but not for the current table, because the user likely is disturbed by such a select.
An other solution would be, to add all new songs to the end of the table. This is seems to be a major work for a minor problem.

In the attached patch I have prepared the following solution:
* select onShow
* select after library scan
* select after drop a track ?field.comment=All changed and new tracks where signalled by BaseTrackCache.
One solution would be to do select, if a new track is signalled. This is a good Idea for currently not displayed tables, but not for the current table, because the user likely is disturbed by such a select.
An other solution would be, to add all new songs to the end of the table. This is seems to be a major work for a minor problem.

In the attached patch I have prepared the following solution:
* select onShow
* select after library scan
* select after drop a track

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Changed in mixxx:
milestone: none → 1.11.0
milestone: 1.11.0 → none
Daniel Schürmann (daschuer) wrote :

commited to lp:mixxx/1.11 #3311.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers