no change of searchbox contend when changing library feature

Bug #998836 reported by Daniel Schürmann on 2012-05-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann
1.10
Low
Daniel Schürmann

Bug Description

The serachbox does not display the current search (filter) when moving through the library tree in any case.

Changed in mixxx:
status: New → In Progress
assignee: nobody → Daniel Schürmann (daschuer)
Daniel Schürmann (daschuer) wrote :

the attached patch solves the problem for lp:mixxx #3154.
Bug #995957 is also solved by this patch.

jus (jus) wrote :

We had a discussion about that some month back, we could take the chance and decide now what is the preferred behavior https://bugs.launchpad.net/mixxx/+bug/689291

Daniel Schürmann (daschuer) wrote :

This bug is an issues only for the current behavior.
This is, that every feature saves its current search.

Without the patch, the searchbox is not properly refreshed when moving through the library. This is annoying because sometimes simply a wrong filter is displayed.

I would prefer to commit this patch and to postpone the general thing until we renovating the library view.

I will add my additional comments to Bug #689291.

RJ Skerry-Ryan (rryan) wrote :

There seem to be a few stray tab characters in the patch but otherwise looks good to me (and since it fixes current intended behavior it can go in independent of the discussion in Bug #689291)

Changed in mixxx:
milestone: none → 1.11.0
importance: Undecided → Low
Daniel Schürmann (daschuer) wrote :

Committed lp:mixxx #3247

Changed in mixxx:
status: In Progress → Fix Committed
jus (jus) wrote :

Hi Daniel, just FYI.
It looks like your latest fixes to trunk were committed without the " --fixes lp:XXXXX" option. Because of this the fixed bugs are not automatically linked to the respective branch ( e.g. lp:mixxx ) and are not searchable by bug# with bazaars log function (see screenshot).
http://doc.bazaar.canonical.com/beta/en/tutorials/using_bazaar_with_launchpad.html#changing-the-state-in-launchpad-while-committing-in-bazaar

Daniel Schürmann (daschuer) wrote :

Hi jus, thank you for the hint!

Daniel Schürmann (daschuer) wrote :

Merged to lp:mixxx/1.10 #3107

RJ Skerry-Ryan (rryan) on 2012-11-21
Changed in mixxx:
status: Fix Committed → Fix Released
milestone: 1.11.0 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers