Filtering Auto DJ playlist breaks Auto DJ

Bug #995957 reported by Daniel Schürmann on 2012-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann

Bug Description

It seams that Auto DJ uses the filtered playlist. So when you ecidently put something into the search box and forget to change to library view before, Auto DJ will be run out of Tracks and will stop unexpectedly.

tags: added: autodj
RJ Skerry-Ryan (rryan) on 2012-05-11
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Medium
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

The solution is part of the patch in solved Bug #998836

Hm, it looks like that patch disables search altogether for ADJ. I wonder
how many people use that? It seems like we could instead fix this and still
allow searching by having ADJ use a different playlist-table-model to get
tracks from.

On Sun, May 13, 2012 at 5:07 PM, Daniel Schürmann <<email address hidden>
> wrote:

> The solution is part of the patch in solved Bug #998836
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/995957
>
> Title:
> Filtering Auto DJ playlist breaks Auto DJ
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/995957/+subscriptions
>

Daniel Schürmann (daschuer) wrote :

Yes the patch disables "filtering" the autoDJ list.
I have used the auto DJ last week and its filter function was like a horror, because I often forget to switch to library view before editing the searchbox. In the latest trunk version, auto DJ plays what you see. With your suggestion it plays what you have added.
This is slightly better but still confusing. There must be only rare usecases where filtering Auto DJ is required.
I think this is the same issue why we have disabled sorting.

Daniel Schürmann (daschuer) wrote :

Committed lp:mixxx #3247

Changed in mixxx:
status: In Progress → Fix Committed
milestone: none → 1.11.0
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers