Add horizontal scroll-bar in treeview pane

Bug #976580 reported by Gary Littlemore on 2012-04-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Irina Grosu

Bug Description

On the left pane with Library, AutoDJ, Playlists & Crates etc I have no horizontal slide bar. So when opening browse to find a certain folder I'm not able to slide the screen to find the folder. See the attached screen dump.

I'm using 1.10.0 x64 build r3034 on Win 7 x64.

Daniel Schürmann (daschuer) wrote :

As quick solution you may drag the splitter.

This bug should be solved together with bug #974619

RJ Skerry-Ryan (rryan) on 2012-04-30
Changed in mixxx:
importance: Undecided → Wishlist
jus (jus) on 2012-06-17
tags: added: easy usability
Changed in mixxx:
status: New → Confirmed
summary: - No horizontal slide bar
+ Add horizontal scroll-bar in treeview pane
mutil (mutil) wrote :

Have a look also at lp:925628 .Related, proposes another solution to the same problem.

Irina Grosu (irnuk) on 2013-05-21
Changed in mixxx:
assignee: nobody → Irina Grosu (irnuk)
status: Confirmed → In Progress
Irina Grosu (irnuk) wrote :

If the content of the tree view exicides its size, the horizontal scroll bar appears and is sized according to the new content. After the tree view is collapsed and the content fits the tree view's size the horizontal scroll bar disappears.

Owen Williams (ywwg) wrote :

Looks good, thanks! Targetting to 1.12 because it's not a critical bug.

Changed in mixxx:
status: In Progress → Fix Committed
milestone: none → 1.12.0
Owen Williams (ywwg) wrote :

Looks like I failed to actually commit this somehow. Trying again soon.

Changed in mixxx:
status: Fix Committed → In Progress
Owen Williams (ywwg) on 2013-05-22
Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers