Drop Icons in AutoDJ tab in favor of buttons

Bug #953232 reported by jus on 2012-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
jus

Bug Description

This belongs to the improved AutoDJ functionality in lp:mixxx

One thing we should really consider is to drop the hot Icons (icons with function) in AutoDJ tab in favor of buttons.

Why?
* Use unambiguous "Call to action" buttons as common in Mixxx
* Button text & explanatory tooltips are translatable
* Still possible to customize the buttons in skin definitions

See picture for comparison between proposed layout/current layout.

jus (jus) wrote :
RJ Skerry-Ryan (rryan) wrote :

makes sense.. I had to hover to see the tooltip to know what those buttons did anyway.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
jus (jus) wrote :

Patch removes icons and replaces them with buttons like in the picture above, updates the tooltips and adds a disambiguation for translators.

Looks good -- go ahead and commit it.

On Tue, Mar 13, 2012 at 12:55 PM, jus <email address hidden> wrote:

> Patch removes icons and replaces them with buttons like in the picture
> above, updates the tooltips and adds a disambiguation for translators.
>
> ** Patch added: "autodj_buttons.patch"
>
> https://bugs.launchpad.net/mixxx/+bug/953232/+attachment/2863962/+files/autodj_buttons.patch
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/953232
>
> Title:
> Drop Icons in AutoDJ tab in favor of buttons
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/953232/+subscriptions
>

jus (jus) on 2012-03-17
Changed in mixxx:
status: Confirmed → Fix Committed
assignee: nobody → jus (jus)
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers