1.10 crashes while loading tracks

Bug #926452 reported by David Weary on 2012-02-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Unassigned

Bug Description

I am using a laptop with windows 7, intel i7-2630qm 64 bit OS 2.0 Ghz and radeon graphics card. I have down loaded both 32 bit and 64 bit versions of 1.10. After a short time the program stops and shuts down. This seems to occur while dropping a new track on to the player. I have read some of the bug problems and I tried turning off the Wave form function. But the program still stops playing then shuts down. I am not a programmer so I don't know if I can be of any more assistance. I hope this helps.

Log Name: Application
Source: Application Error
Date: 2/3/2012 3:01:34 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: David-HP
Description:
Faulting application name: mixxx.exe, version: 0.0.0.0, time stamp: 0x4ef52d1c
Faulting module name: QtCore4.dll, version: 4.7.4.0, time stamp: 0x4e9e73c4
Exception code: 0xc0000005
Fault offset: 0x0009b295
Faulting process id: 0x1c78
Faulting application start time: 0x01cce2c70f7f08e1
Faulting application path: C:\Program Files (x86)\Mixxx\mixxx.exe
Faulting module path: C:\Program Files (x86)\Mixxx\QtCore4.dll
Report Id: 040d8be7-4ebb-11e1-b859-9599a4dd9bae
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-02-03T23:01:34.000000000Z" />
    <EventRecordID>29798</EventRecordID>
    <Channel>Application</Channel>
    <Computer>David-HP</Computer>
    <Security />
  </System>
  <EventData>
    <Data>mixxx.exe</Data>
    <Data>0.0.0.0</Data>
    <Data>4ef52d1c</Data>
    <Data>QtCore4.dll</Data>
    <Data>4.7.4.0</Data>
    <Data>4e9e73c4</Data>
    <Data>c0000005</Data>
    <Data>0009b295</Data>
    <Data>1c78</Data>
    <Data>01cce2c70f7f08e1</Data>
    <Data>C:\Program Files (x86)\Mixxx\mixxx.exe</Data>
    <Data>C:\Program Files (x86)\Mixxx\QtCore4.dll</Data>
    <Data>040d8be7-4ebb-11e1-b859-9599a4dd9bae</Data>
  </EventData>
</Event>

jus (jus) wrote :

Related to lp:908546 and lp:888773 ?

David Weary (davidedoo) wrote :

I don't think my bug is related. One track that is playing will stop and there is no evidence that it was there. the other side will play for a short period of time then also stop. Finally, the program closes. I have no system freezing issuses. I can restart the program and run it for awhile then it stops like before.

Can you please post the last few lines of your mixxx.log file as well?

Sean, Not sure were to find those?
 David Weary

________________________________
From: Sean M. Pappalardo <email address hidden>
To: <email address hidden>
Sent: Wed, February 8, 2012 4:34:48 AM
Subject: [Bug 926452] Re: 1.10 crashes while loading tracks

Can you please post the last few lines of your mixxx.log file as well?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/926452

Title:
  1.10 crashes while loading tracks

Status in Mixxx:
  New

Bug description:
  I am using a laptop with windows 7, intel i7-2630qm 64 bit OS 2.0 Ghz
  and radeon graphics card. I have down loaded both 32 bit and 64 bit
  versions of 1.10. After a short time the program stops and shuts down.
  This seems to occur while dropping a new track on to the player. I
  have read some of the bug problems and I tried turning off the Wave
  form function. But the program still stops playing then shuts down. I
  am not a programmer so I don't know if I can be of any more
  assistance. I hope this helps.

  Log Name: Application
  Source: Application Error
  Date: 2/3/2012 3:01:34 PM
  Event ID: 1000
  Task Category: (100)
  Level: Error
  Keywords: Classic
  User: N/A
  Computer: David-HP
  Description:
  Faulting application name: mixxx.exe, version: 0.0.0.0, time stamp: 0x4ef52d1c
  Faulting module name: QtCore4.dll, version: 4.7.4.0, time stamp: 0x4e9e73c4
  Exception code: 0xc0000005
  Fault offset: 0x0009b295
  Faulting process id: 0x1c78
  Faulting application start time: 0x01cce2c70f7f08e1
  Faulting application path: C:\Program Files (x86)\Mixxx\mixxx.exe
  Faulting module path: C:\Program Files (x86)\Mixxx\QtCore4.dll
  Report Id: 040d8be7-4ebb-11e1-b859-9599a4dd9bae
  Event Xml:

    <System>
      <Provider Name="Application Error" />
      <EventID Qualifiers="0">1000</EventID>
      <Level>2</Level>
      <Task>100</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2012-02-03T23:01:34.000000000Z" />
      <EventRecordID>29798</EventRecordID>
      <Channel>Application</Channel>
      <Computer>David-HP</Computer>
      <Security />
    </System>
    <EventData>
      <Data>mixxx.exe</Data>
      <Data>0.0.0.0</Data>
      <Data>4ef52d1c</Data>
      <Data>QtCore4.dll</Data>
      <Data>4.7.4.0</Data>
      <Data>4e9e73c4</Data>
      <Data>c0000005</Data>
      <Data>0009b295</Data>
      <Data>1c78</Data>
      <Data>01cce2c70f7f08e1</Data>
      <Data>C:\Program Files (x86)\Mixxx\mixxx.exe</Data>
      <Data>C:\Program Files (x86)\Mixxx\QtCore4.dll</Data>
      <Data>040d8be7-4ebb-11e1-b859-9599a4dd9bae</Data>
    </EventData>
  </Event>

To manage notifications about this bug go to:
https://bugs.launchpad.net/mixxx/+bug/926452/+subscriptions

http://mixxx.org/wiki/doku.php/troubleshooting#where_is_the_mixxxlog_file

And actually, please attach the whole file. (Click "Add attachment or patch" under the bug comment box .)

David Weary (davidedoo) wrote :

Sorry, This is so above my head at this point. Just disappointed the program fails.

Just click Start->Computer, then at the top of the new window where it says Computer, click and type %LOCALAPPDATA%\Mixxx and press Enter. The folder it brings you to should have a mixxx.log file in it. Just attach that to this bug.

Albert Santoni (gamegod) wrote :

Hi David,

Thanks for taking the time to report the bug. Between the information you've given us and what we can gather from a few other bug reports, I think we have enough clues to track down the crash. There seems to be an intermittent crash affecting some Windows systems, either caused by our new audio decoding code or packaging issues with our build server.

Either way, this is a very serious bug and we'll get this fixed for our next release.

Once again, thanks for helping us out, and I hope we can get Mixxx working reliably for you.
Albert

Albert Santoni (gamegod) wrote :

Hi David,

I have experimented with some changes in our build environment, and I've produced a new test build for you to try. There's three quick things I need you to try, if you have time:

1) Uninstall whatever version of Mixxx you have installed.

2) Download and install this new test version of Mixxx:

http://downloads.mixxx.org/targeted/mixxx-1.10-033112-msvc2008-x86-albert.exe

3) Download and install this Microsoft C++ Runtime package:

http://downloads.mixxx.org/targeted/vcredist_x86.exe
(If it only gives you the option to "Repair" or "Remove", you don't need to install it.)

Please let us know if this fixes the crash on startup you're experiencing! These bugs are critical for us, and we appreciate your cooperation in helping us figure it out.

Thanks,
Albert

Changed in mixxx:
importance: Undecided → Critical
milestone: none → 1.10.1
David Weary (davidedoo) wrote :
Download full text (3.7 KiB)

Thanks, I'll check it out tomorrow, and let u know.

T-Mobile. America’s First Nationwide 4G Network

----- Reply message -----
From: "Albert Santoni" <email address hidden>
To: <email address hidden>
Subject: [Bug 926452] Re: 1.10 crashes while loading tracks
Date: Sat, Mar 31, 2012 8:45 pm

Hi David,

I have experimented with some changes in our build environment, and I've
produced a new test build for you to try. There's three quick things I
need you to try, if you have time:

1) Uninstall whatever version of Mixxx you have installed.

2) Download and install this new test version of Mixxx:

http://downloads.mixxx.org/targeted/mixxx-1.10-033112-msvc2008-x86-albert.exe

3) Download and install this Microsoft C++ Runtime package:

http://downloads.mixxx.org/targeted/vcredist_x86.exe
(If it only gives you the option to "Repair" or "Remove", you don't need to install it.)

Please let us know if this fixes the crash on startup you're
experiencing! These bugs are critical for us, and we appreciate your
cooperation in helping us figure it out.

Thanks,
Albert

** Changed in: mixxx
   Importance: Undecided => Critical

** Changed in: mixxx
    Milestone: None => 1.10.1

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/926452

Title:
  1.10 crashes while loading tracks

Status in Mixxx:
  New

Bug description:
  I am using a laptop with windows 7, intel i7-2630qm 64 bit OS 2.0 Ghz
  and radeon graphics card. I have down loaded both 32 bit and 64 bit
  versions of 1.10. After a short time the program stops and shuts down.
  This seems to occur while dropping a new track on to the player. I
  have read some of the bug problems and I tried turning off the Wave
  form function. But the program still stops playing then shuts down. I
  am not a programmer so I don't know if I can be of any more
  assistance. I hope this helps.

  Log Name: Application
  Source: Application Error
  Date: 2/3/2012 3:01:34 PM
  Event ID: 1000
  Task Category: (100)
  Level: Error
  Keywords: Classic
  User: N/A
  Computer: David-HP
  Description:
  Faulting application name: mixxx.exe, version: 0.0.0.0, time stamp: 0x4ef52d1c
  Faulting module name: QtCore4.dll, version: 4.7.4.0, time stamp: 0x4e9e73c4
  Exception code: 0xc0000005
  Fault offset: 0x0009b295
  Faulting process id: 0x1c78
  Faulting application start time: 0x01cce2c70f7f08e1
  Faulting application path: C:\Program Files (x86)\Mixxx\mixxx.exe
  Faulting module path: C:\Program Files (x86)\Mixxx\QtCore4.dll
  Report Id: 040d8be7-4ebb-11e1-b859-9599a4dd9bae
  Event Xml:
  <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
      <Provider Name="Application Error" />
      <EventID Qualifiers="0">1000</EventID>
      <Level>2</Level>
      <Task>100</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2012-02-03T23:01:34.000000000Z" />
      <EventRecordID>29798</EventRecordID>
      <Channel>Application</Channel>
      <Computer>David-HP</Computer>
      <Security />
    </System>
    <EventData>
      <Data>mixxx.exe</Data>
      <D...

Read more...

Mulachak Hachoki (bachola) wrote :
Download full text (9.3 KiB)

I'm running Mixx on ubuntu 11.10 on an intel celeron 2.5 ghz

Mix crashes when I load a track. Below is what happens.

:~$ /usr/bin/mixxx results in
Debug: [Main]: Mixxx 1.10.0 "(built on: Dec 25 2011 @ 04:49:42; flags: hifieq mad midiscript optimize=9 qdebug shoutcast verbose vinylcontrol)" is starting...
Debug: [Main]: Qt version is: 4.7.4
Debug: [Main]: Configuration file is at the current version 1.10.0
Debug: [Main]: Loading translations for locale "en_US" from translations folder "/usr/share/mixxx/translations/" : fail
Debug: [Main]: Found folder 'Mixxx' within default OS music directory
Debug: [Main]: Could not create folder 'Recordings' within 'Mixxx'
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel1]" , "vinylcontrol_mode" )
Debug: [Main]: ControlObject::getControl returning NULL for ( "[Channel2]" , "vinylcontrol_mode" )
Debug: [Main]: JACK client name set
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.ICH4.pcm.surround71.0:CARD=0'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM surround71
ALSA lib setup.c:565:(add_elem) Cannot obtain info for CTL elem (MIXER,'IEC958 Playback Default',0,0,0): No such file or directory
ALSA lib setup.c:565:(add_elem) Cannot obtain info for CTL elem (MIXER,'IEC958 Playback Default',0,0,0): No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Debug: [Main]: Available QtSQL drivers: ("QSQLITE", "QMYSQL3", "QMYSQL")
Debug: [Main]: src/library/trackcollection.cpp DB status: true
Debug: [Main]: SchemaManager::upgradeToSchemaVersion already at version 13
Debug: [Main]: TrackDAO::initialize QThread(0xa0885d0, name = "Main") "qt_sql_default_connection"
Debug: [Main]: CrateDAO::initialize()
Debug: [Main]: CueDAO::initialize QThread(0xa0885d0, name = "Main") "qt_sql_default_connection"
Debug: [Main]: Promo dir: "/u...

Read more...

Darrin Costantini (darrinjc) wrote :

I didn't see a response to the suggestion of downloading the alpha version. Just wanted to let you know that I had the same issue that the OP had and the alpha version appears to have allowed me to operate the program. Thanks very much for the update.

One item with the Alpha: There does not appear to be a *.MP4 / *.M4A plug-in contained in the Alpha. the link under preferences does not appear to link to any plug-ins. Can you point me to, or provide more details, on what the plug-in is or where an MP4 plug-in may be available.

Thanks in advance!

RJ Ryan (rryan) wrote :

Hi all,

Can you please try out 1.11.0 beta so we can make sure we've fixed this?

http://builds.mixxx.org/builds/release-1.11.x/r3487/

Thanks!

Changed in mixxx:
status: New → Incomplete
Uwe Klotz (uklotzde) wrote :

Marked as invalid due to no activity.

Changed in mixxx:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers