Auto DJ drag file to new position stopped working

Bug #926119 reported by stefanazar on 2012-02-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Unassigned
1.10
Medium
Unassigned
1.11
Medium
Unassigned

Bug Description

I originally reported this issue regarding the prior release ( case # 897756 ) and was fixed in 1.10.0 but now

Im having a occurrence of this issue. It was fixed in 1.10 and worked well for a while but now after 2 or 3 weeks its happening again.

I believe it has something to do with the mixxdb.sqlite file getting corrupted over time somehow.

I say this because when I substitute an older version of the file into the folder, the behavior returns to normal. When I switch it back to the current file , it returns.

This happens in Windows 7 as well as XP.

Regards

jus (jus) wrote :

Couldn't we make a diff between the both mixxdb.sqlite files and look for any anomalies?

summary: - Auto DJ drag file to new psoition stopped working
+ Auto DJ drag file to new position stopped working
jus (jus) wrote :

Related to lp:917600
(Duplicate?)

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 1.10.1
stefanazar (stefanazar) wrote :

Would it help if i provided a working mixxdb.sqlite and a non-working mixxdb.sqlite and possibly an anomaly could be ound?

In any case attached is one that seems to be causing the bug.

Joe Salvino (joe-zwnfz) wrote :

Just FYI, I have the same issue of no re-order ability in Auto DJ too. Same as other user who reported that it did work at first, and now for some reason it doesn't. Any new tracks added to play list are dropped in alphabetically by Song Title. No way to move them once dropped inside either.

Using Windows Vista 64 bit with MIXXX v.10.0

RJ Skerry-Ryan (rryan) on 2012-11-21
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2012-11-21
Changed in mixxx:
milestone: 1.10.1 → none
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers