Choose recording folder.

Bug #925663 reported by mutil on 2012-02-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Ilkka Tuohela

Bug Description

Mixxx automatically creates an empty folder (Mixxx/Recordings) inside the music Library.
I think the location should be configurable, and only create it the first time a user wishes to record (preferably after user interaction).

RJ Skerry-Ryan (rryan) on 2012-02-02
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
summary: - recording folder
+ Choose recording folder.
Ilkka Tuohela (hile) wrote :

Attached is a patch which adds a library preference to set recordings folder to config key "Recording","Directory". The setting is modified from the 'Recordings' configuration page.

Initially when user has not selected a setting for this folder, we construct the current path (Mixxx/Recordings under music library) and set it as default value in configuration.

The patch checks and changes recording folder whenever user clicks on the 'Recordings' sidebar after changing the folder in preferences.

Patch is against trunk as of today (2012-04-21).

It might be good idea to set a default value in new install configurations to something like $HOME/Music/Mixxx/Recordings instead of writing by default to user's music library: this however is not relevant for this patch.

jus (jus) on 2012-04-23
Changed in mixxx:
assignee: nobody → Ilkka Tuohela (hile)
status: Confirmed → In Progress
milestone: none → 1.11.0
RJ Skerry-Ryan (rryan) wrote :

Thanks hile! Please sign the contributor agreement here to give us permission to distribute your patch w/ mixxx: https://docs.google.com/a/mixxx.org/spreadsheet/viewform?formkey=dEpYN2NkVEFnWWQzbkFfM0ZYYUZ5X2c6MQ#gid=0

Changed in mixxx:
status: In Progress → Fix Committed
mutil (mutil) wrote :

This doesn't seem to work for me on a linux box.
It always writes to the directory from where mixxx was launched.
The directory in UI and in .cfg file is irrelevant.

Changed in mixxx:
status: Fix Committed → Confirmed
Daniel Schürmann (daschuer) wrote :

I can confirm that. I think there were some lines lost during commit.
Fixed in lp:mixxx #3172

Changed in mixxx:
status: Confirmed → Fix Committed
jus (jus) wrote :

The fix from #4 work only if you choose a custom Recording Directory. Per default Mixxx still writes to the program directory. See lp:1000067

Daniel Schürmann (daschuer) wrote :

Since this bug is "Fix committed" the latest issue #5 is tracked in bug #1000067.

RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers