AutoDJ queue reorder not possible (sometimes)

Reported by daniel on 2012-01-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann
1.10
Medium
Daniel Schürmann

Bug Description

Hi.
Strange error here on Arch64 mixxx1.10 vms4.

Sometimes and very hard to reproduce i start mixxx, throw some songs in the AutoDJ queue and then i'm not able to reorder this queue.
The Values column # change, but songs stay at their position.

CLI output is:
Debug: [Main]: PlaylistTableModel(0x230b520) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x230b520) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x230b520) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x230b520) select() took 1 ms

for Autoshuffle:
Debug: [Main]: Shuffling AutoDJ playlist
Debug: [Main]: Swapping tracks 14 and 9
Debug: [Main]: Swapping tracks 13 and 9
Debug: [Main]: Swapping tracks 12 and 8
Debug: [Main]: Swapping tracks 11 and 15
Debug: [Main]: Swapping tracks 10 and 13
Debug: [Main]: Swapping tracks 9 and 10
Debug: [Main]: Swapping tracks 8 and 15
Debug: [Main]: Swapping tracks 7 and 9
Debug: [Main]: PlaylistTableModel(0x260d3d0) select() took 0 ms
Debug: [Main]: Shuffling done

nothing more. just the # of the dragged&dropped songs changes,
for example from 4/14 to 14/4,
but the songs stay at their positions
Deactivating AutoDJ [Button] does not help.
Exiting and restarting Mixxx neither.
Clicking on the colum heads does nothing, no sorting up/down in no colum.
----------------------
Then[!]
Restarting again, and it works! And debug output is:
Debug: [Main]: PlaylistTableModel(0x3555550) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x3555550) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x3555550) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x3555550) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x3555550) select() took 1 ms

for reordering and for autoshuffle:
Debug: [Main]: Shuffling AutoDJ playlist
Debug: [Main]: Swapping tracks 14 and 10
Debug: [Main]: Swapping tracks 13 and 6
Debug: [Main]: Swapping tracks 12 and 10
Debug: [Main]: Swapping tracks 11 and 11
Debug: [Main]: Swapping tracks 10 and 8
Debug: [Main]: Swapping tracks 9 and 9
Debug: [Main]: Swapping tracks 8 and 7
Debug: [Main]: Swapping tracks 7 and 10
Debug: [Main]: Swapping tracks 6 and 6
Debug: [Main]: Swapping tracks 5 and 14
Debug: [Main]: Swapping tracks 4 and 5
Debug: [Main]: Swapping tracks 3 and 6
Debug: [Main]: Swapping tracks 2 and 10
Debug: [Main]: PlaylistTableModel(0x3555550) select() took 1 ms
Debug: [Main]: Shuffling done

Everything fine. But.
---------------------------

Then[!]
Restarting, and it doesn't work! You see why i called it strange?
Output is now:
Debug: [Main]: PlaylistTableModel(0x292e5c0) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x292e5c0) select() took 1 ms
Debug: [Main]: PlaylistTableModel(0x292e5c0) select() took 1 ms

HTH

Thank you.

daniel (mail-daniel) on 2012-01-17
description: updated
daniel (mail-daniel) on 2012-01-17
description: updated
daniel (mail-daniel) on 2012-01-31
tags: added: auto-dj
jus (jus) wrote :

Related to lp:926119
(Duplicate?)

Changed in mixxx:
milestone: none → 1.10.1
status: New → Confirmed
importance: Undecided → Medium
Joe Salvino (joe-zwnfz) wrote :

Just FYI, I have the same issue of no re-order ability in Auto DJ too. Same as other user who reported that it did work at first, and now for some reason it doesn't. Any new tracks added to play list are dropped in alphabetically by Song Title. No way to move them once dropped inside either.

Using Windows Vista 64 bit with MIXXX v.10.0

Zed Essex (zedessex) wrote :

I have this same problem on an i5 Imac running Lion. I am just Djing at parties and sometimes leave my setup to go socialize, this problem makes that difficult! Also it means that I have to guess what people want to hear and make up the EXACTplaylist I want to play ahead of time. We all know how well that doens't work!

Zed Essex (zedessex) wrote :

Sorry forgot to say that it worked fine the first time I ran the software, but never again after that.

Daniel Schürmann (daschuer) wrote :

A similar issue is reported at Bug #953251

Daniel Schürmann (daschuer) wrote :

Hi Zed,
which version of Mixxx do you using?
Does your Auto DJ playlist still starts with track #1?

Zed Essex (zedessex) wrote :

The last time this happened the tracks were in order from shortest track length to longest. So I deleted my library file and all was well the next time I used Mixxx. closed it down and came back to it later today, same problem. This time it's sorted by artists in reverse alphabetical order.I am using Mixxx 1.10.0 build r3034 on an 2.7 ghz Intel Core i5 bases Imac with 12 GB of memory. I'm running Mac OS X 10.74 (Lion) I guess for now I'll just delete the library file every time I want to use it.

I had also thought about trying the version on the Apple store just incase it's a different build or something. If it helps the first track int he auto DJ playliost is 171.

Zed

Zed Essex (zedessex) wrote :

Got Mixxx version 1.9.1 from the Apple Store. This version has no shuffle feature to go wrong! However it seems to automatically randomize whatever playlist you drag in. It's missing some of the cool looping features of the newer version. But if you're doing internet radio type shows or Djing house parties with sort of non-dance/electronic music you won't miss out on anything.

So if you don't need the advanced looping features of 1.10, this might be a good option for you.

Daniel Schürmann (daschuer) wrote :

Hi Zed,

Thank you for the additional Information!

I suppose this issue is caused by the Auto DJ sorting and filtering function we have accidentally enabled in 1.10.
The Auto DJ Playlist should always start with #1, if not, this is the root cause.

I will have a look!

We are currently working on Mixxx 1.11 which solved many auto DJ issues.
If you like you can test my branch:
http://builds.mixxx.org/builds/experimental-daschuers_trunk/mixxx-1.11.0-alpha2-daschuer~daschuers-trunk-bzr2986-macintel32.dmg

I am not sure which of these problems are solved in the upcoming Bugfix release 1.10.1 but you may give also
mixxx-1.10.1-alpha-macintel32.dmg
a try.

Please backup your ~/.mixxx first and do not use them live!

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
Zed Essex (zedessex) wrote :

Thanks, I noticed that even 1.9.1 had the same sort of problems. I guess auto dj is a recent addition, I hope 1.11 will solve it!

Zed Essex (zedessex) wrote :

Version 1.11 looks great. Shuffle still doesn't work but I like the way the waveforms look now. I also like the Fade now feature and that you can set the fade duration at will. Pretty cool features. As for the shuffle it's still dong the same thing as version 1.10. It also seems to be intentionally looking in the wronk place for soem of my files! Very strange.

Zed Essex (zedessex) wrote :

Just tried out the 1.10 bugfix version. Auto DJ does not work AT ALL on this version! Doesn't seem like I'm gonna win this one! Thanks for trying tho Daniel I appreciate the quick response.

Daniel Schürmann (daschuer) wrote :

Hi Zed

Thank you for testing.
Can you confirm that your AutoDJ playlist still starts with #171?
If yes , you may try with a fresh Mixxx database.

Please try 1.10.0 alpha again and rename the file
Users/<username>/Library/Application Support/Mixxx/mixxxdb.sqlite
to something like
Users/<username>/Library/Application Support/Mixxx/mixxxdb.sqlite.back

Do not delete the old database. W may need it for further tests.
If the issue is now solved I will add a piece of code to shift the playlist back to #1

-------

> It also seems to be intentionally looking in the wrong place for some of my files! Very strange.
Please give more details in a separate Bug report.

------

Something else off topic:
If you like you, can test Bug #1000187 "Menubar always visible in fullscreen mode Mac OSX"
Please check if the menubar behaves as it should after skin change and in fullscreen mode.
And leave your results there.

Thank you,

Daniel

Daniel Schürmann (daschuer) wrote :

The attached patch solves the problem against lp;mixxx #3201

Changed in mixxx:
status: Confirmed → In Progress
milestone: 1.10.1 → 1.11.0
RJ Ryan (rryan) wrote :

Patch looks good to me.

Daniel Schürmann (daschuer) wrote :

Fix committed to lp:mixxx #3246

Changed in mixxx:
status: In Progress → Fix Committed
daniel (mail-daniel) wrote :

Works as intended now! Thank You!

Daniel Schürmann (daschuer) wrote :

Merged to lp:mixxx/1.10 #3107

jus (jus) wrote :

Bug is back again in lp:mixxx/1.11 r3424 , exactly as described in the initial post
Tested with MacOSX 10.8.6

RJ Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers