apply in metadata closes window

Bug #913255 reported by daniel on 2012-01-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
mutil

Bug Description

if i want to edit metadata i right-klick on a file, choose preferences, and edit the data. then i press apply and the window closes. expected behaviour is to keep that window open to use these shiny previous/next buttons for mass editing :-)

mixxx 1.10 archlinux 64

daniel (mail-daniel) on 2012-01-07
description: updated
RJ Skerry-Ryan (rryan) on 2012-01-08
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
tags: added: usability
mutil (mutil) on 2012-06-24
Changed in mixxx:
assignee: nobody → mutil (mutil)
status: Confirmed → In Progress
mutil (mutil) wrote :

Attached patch fixes this issue and adds an OK button.

Now the buttons have the expected behaviour:
*Cancel --- Discard changes and close the window
*Apply --- Save changes and keep the window open
*OK --- Save changes and close the window

It also hides key field until it is implemented, because now it doesn't work properly and it gets confusing.

jus (jus) wrote :
Changed in mixxx:
milestone: none → 1.12.0
jus (jus) on 2013-12-11
Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers