Add preference option to Library section to disable iTunes/Traktor/Rhythmbox features

Bug #909395 reported by Ilkka Tuohela on 2011-12-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Daniel Schürmann

Bug Description

I would like to see an option in library preferences to not show/load itunes and traktor libraries in the sidebar, or even trying to connect to these in the first place.

I have both programs installed, but manage playlists for mixxx separately, and all three libraries contain always exactly same songs as my mixxx library: for me, there is no point going to these tree nodes, and loading them just slows down the UI.

Related branches

Daniel Schürmann (daschuer) wrote :

An option for disabling the iTunes node is included in patch from Bug #826026.

Changed in mixxx:
status: New → Confirmed
jus (jus) on 2011-12-30
summary: - Add option to disable itunes and traktor libraries
+ Add preference option to Library section to disable
+ iTunes/Traktor/Rhythmbox features
Changed in mixxx:
importance: Undecided → Wishlist
RJ Skerry-Ryan (rryan) on 2012-01-07
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
milestone: none → 1.10.1
milestone: 1.10.1 → 1.11.0
Daniel Schürmann (daschuer) wrote :

The attached patch solves the bug. It's against lp:mixxx #2986.
Note: Mixxx restart is required after changing propertys in library.

RJ Skerry-Ryan (rryan) wrote :

Patch looks good to me but the config option "ShowTracktorLibrary" mis-spells Traktor. Feel free to commit to trunk after fixing the spelling.

Thanks,
RJ

RJ Skerry-Ryan (rryan) wrote :

I had some free time so I went ahead and made the changes and committed. Thanks!

Changed in mixxx:
status: In Progress → Fix Committed
Max Linke (max-linke) wrote :

Mixxx should tell the user that he has to restart it for this change to take effect.

this page edits the .ui file and tells the user to restart mixxx

Daniel Schürmann (daschuer) wrote :

Hi Max,

Good idea and very simple!
Since this Bug has already the state "Fix Commited", you should file a different bug and add your path there.

RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers