Push-buttons are getting out of sync using both mouse buttons

Bug #906310 reported by Don Paul on 2011-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

Mixxx 1.10.0-beta1x64 on Windows home premium 64:

Reverse and Fast Rewind buttons keep going past the start of a song - I think they should stop there.

Pressing Reverse with right and left mouse buttons together can cause reverse play to keep going, even again after pause. Repeating this action (which is not always recognised) is the only way to stop the reverse playing.

Worse still I managed to get a tune to play very fast in forward while testing this out and could only stop it by shutting down Mixxx. The Play/Pause button had no effect.

The Reverse button implementaion is not solid.

Changed in mixxx:
status: New → Confirmed
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
Daniel Schürmann (daschuer) wrote :

Note: The "going past the start of the song" issue is tracked in a separate bug #906353

I think the best solution is, to compete decouple the right and left mouse button for push-buttons.
Or is there any reason to control a push-button by the right mouse button as well?

The only reason for me the user might want to clicks the right button is when expecting latching function.
A proposal for this can be found in bug #876139. Does anyone like to see such a power-window button button for reverse-play as well?

summary: - Reverse very wrong.
+ Push-buttons are getting out of sync using both mouse buttons
Daniel Schürmann (daschuer) wrote :

One issue with wpushbutton is is the inverse mode of a single state push-button.

m_fValue = emitValue = (m_fValue == 0.0f) ? 1.0f : 0.0f;

This conflicts with the midi and keyboard buttons, which don't have such an inverse mode. I don't now if there is a use case for this function. So if not, I will remove this "feature".

Changed in mixxx:
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Attached you will find a patch against lp:mixxx #2973 which should solve the most pushbutton issues.
It introduces also the power-window mode from Bug #876139.

RJ Skerry-Ryan (rryan) wrote :

RE: The reversing past the start of the song, that's intended behavior as the track-lead in area is treated just as part of the track itself.

Changed in mixxx:
milestone: none → 1.11.0
jus (jus) on 2012-03-13
Changed in mixxx:
importance: Undecided → Low
RJ Skerry-Ryan (rryan) wrote :

Bug #876139 is now fixed so this one should be fixed as well. Thanks Daniel!

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers