MIDI scratch drag incorrect at other than 0% pitch

Reported by Sean M. Pappalardo on 2011-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Sean M. Pappalardo

Bug Description

When releasing a controller wheel after scratching, the target play speed is incorrect when at a pitch other than 0%.

Is this related to scripts or Mixxx engine scratch code?

On Mon, Dec 12, 2011 at 10:23 AM, Sean M. Pappalardo <
<email address hidden>> wrote:

> Public bug reported:
>
> When releasing a controller wheel after scratching, the target play
> speed is incorrect when at a pitch other than 0%.
>
> ** Affects: mixxx
> Importance: Low
> Status: Confirmed
>
>
> ** Tags: midi scratching
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/903244
>
> Title:
> MIDI scratch drag incorrect at other than 0% pitch
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/903244/+subscriptions
>

MSE::scratchProcess() is responsible for the problem right now.

Fixed in features_controllerAbstraction. Not sure what exactly fixed it, but it works correctly as of r2812.

Changed in mixxx:
status: Confirmed → Fix Committed
assignee: nobody → Sean M. Pappalardo (pegasus-renegadetech)
milestone: none → 1.11.0
status: Fix Committed → In Progress
Changed in mixxx:
status: In Progress → Fix Committed
RJ Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers