losing keyboard release events

Bug #900255 reported by Daniel Schürmann on 2011-12-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

If you press a keyboard key, then press a modifier key, then release the key, you will get the press event without modifier and the release event with modifier.

Example:
* Press and hold "1" for Sync, press and hold Shift, release 1.
-> Sync button is always lit.

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: New → In Progress
Daniel Schürmann (daschuer) wrote :

I am working on a solution where the modifier key is only taken into account when pressing a key. The release event is always fired, matching to the press event.

There is still a problem with Mac OSX and keys with different letters like "1" and "!" because Max OSX does not report the native scan code of the keys. Mixxx does not know whether the letters are on the same key or not.

Maybe a Mac OSX expert has an Idea?

RJ Skerry-Ryan (rryan) on 2011-12-05
summary: - loosing keyboard release events
+ losing keyboard release events
tags: added: keyboard
Changed in mixxx:
importance: Undecided → Low
Daniel Schürmann (daschuer) wrote :

here it is:

Daniel Schürmann (daschuer) wrote :

New version: Missing return caused searching in library; silenced debug output.

Daniel Schürmann (daschuer) wrote :

Just tested on Win-XP. There seems to be an issue with ^ on German keyboards. I will have a look.

Daniel Schürmann (daschuer) wrote :

Here is a modified patch, solves an issue with autorepeat on WinXP. The dead key ^ issue is tracked in the separate bug #907199.

RJ Skerry-Ryan (rryan) on 2012-01-07
Changed in mixxx:
milestone: none → 1.11.0
Daniel Schürmann (daschuer) wrote :

Bug #684501 was marked as duplicate of this bug. It was tagged as 1.10.1 milestone.
Should we so add this patch also to 1.10.1 as well?

RJ Skerry-Ryan (rryan) wrote :

patch looks good.. thanks!

RJ Skerry-Ryan (rryan) wrote :

RE: 1.10.1 -- I'd rather keep changes like this limited to 1.11.0 so that we don't accidentally break keyboard shortcuts for people just upgrading to 1.10.1 if there is a bug we don't realize yet.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers