Spinning vinyl widget (WSpinny) incorrectly rendered on Ubuntu 11.10 Oneiric

Bug #887269 reported by zniavre on 2011-11-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann
1.10
Undecided
Unassigned
1.11
Medium
Daniel Schürmann

Bug Description

using mixxx beta 1.10 on oneiric everything seems properly setup
the new vynil control thingy seems broken it displays a square turning instead of vinyl image

attached screenshot with error

if i can provide more information, let me know

zniavre (zniavre2048-gmail) wrote :

To get the basics out of the way: What type of video card do you have? Are you using proprietary or open-source drivers for it? Are they up-to-date? What Qt version is on your system? (Run qtconfig then click Help->About Qt.)

RJ Skerry-Ryan (rryan) on 2011-11-07
summary: - mixxx 1.10 beta oneiric vinyl control
+ WSpinny renders wrong in mixxx 1.10 beta in Oneiric.
RJ Skerry-Ryan (rryan) on 2011-11-07
Changed in mixxx:
importance: Undecided → Medium
milestone: none → 1.10.0

I can confirm it on my PC.

* QT Version Qt version 4.7.4.
* I use the X.Org-X-Server – AMD/ATI-Radeon-Grafiktreiber 1:6.14.99~git20110811.g93fc084ubuntu1 (oneiric)
* ATI Technologies Inc RV710 [Radeon HD 4350]

This bug occurs in unity and also in gnome shell.

Daniel Schürmann (daschuer) wrote :

I checked also lp:mixxx #2941 on my eeePC with worse results. Instead of the spinny widget, an empty white box is displayed.

* Ubuntu Lucid
* QT Version Qt version 4.6.2.
* Intel 945GME

For the record, it works fine for me using:
* Debian Squeeze
* nVidia NVS 3100M (using the proprietary nVidia driver)
* Qt 4.6.3

zniavre (zniavre2048-gmail) wrote :

QT version : 4.7.4
radeon open source drivers with 9600 pro ati gfx

im using lastest gnome3.2 with oneiric and gnome-panel session (fallback)

it displays this "square" with metacity too

Owen Williams (ywwg) wrote :

We should probably find a QT guru asap who can help troubleshoot this issue. It sounds like a deep-dark Xorg / QT / GL interaction.

RJ Skerry-Ryan (rryan) wrote :

Can you guys who can reproduce try this skin? It's just a spinny widget and nothing else.

I can't reproduce on Lucid amd64 on a Lenovo T400 with Intel GMA 4500MHD graphics card. I also can't reproduce in VirtualBox with an Oneiric amd64 VM on Mixxx 1.10.0 beta.

ii xserver-xorg-video-intel 2:2.9.1-3ubuntu5 X.Org X server -- Intel i8xx, i9xx display driver
ii xorg 1:7.5+5ubuntu1 X.Org X Window System

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
i945

Changed in mixxx:
status: New → Confirmed
RJ Skerry-Ryan (rryan) wrote :

This is likely related to Bug #792237 in which many widgets are white (Daniel reported WSpinny as white on his netbook which is probably confirmation of that bug).

tags: added: ati intel wspinny
Daniel Schürmann (daschuer) wrote :

With Test Skin, the squared spinny widget is displayed as in all other skins on system from #3

Daniel Schürmann (daschuer) wrote :

I just notice that the cue mark is also effected by this bug on system #3 with Deere Skin.
All other Skins does not suffer the cue mark bug.

And one important thing: outline skin displays spinny correct!

Daniel Schürmann (daschuer) wrote :

The magic "QT_GL_USE_OPENGL1ENGINE=1 mixxx" solves this problem as well on system #3.
The spinny an the cure marks are displayed correct now.

Daniel Schürmann (daschuer) wrote :

Now I am on my System #4. The spinny is displayed white in a gray window. It is also displayed white in outline skin.
Here QT_GL_USE_OPENGL1ENGINE=1 has no effect.

summary: - WSpinny renders wrong in mixxx 1.10 beta in Oneiric.
+ Spinning vinyl widget (WSpinny) incorrectly rendered on Ubuntu 11.10
+ Oneiric
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
milestone: 1.10.0 → 1.10.1
Daniel Schürmann (daschuer) wrote :

Patch from Bug #981210 should solve this issue

Changed in mixxx:
status: Confirmed → In Progress
assignee: nobody → Daniel Schürmann (daschuer)
milestone: 1.10.1 → none
Daniel Schürmann (daschuer) wrote :

Hope this is entirely solved together with Bug #981210
finally fixed in lp:mixxx/1.11 #3622.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers