Vinyl Control suddenly freezes and stops playing

Bug #886551 reported by Owen Williams on 2011-11-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Owen Williams
1.10
Critical
Unassigned

Bug Description

During a mix using digital vinyl control, the first deck suddenly stopped playing. I did not take any action at the time that might have triggered this. Mixxx did not crash, it was just a sudden halt to playback. The WSpinny timecode signal overlay was frozen. Everything else continued to work. Going in to preferences and looking at vinyl preferences, the signal widget there was still working (!). Re-applying the vinyl settings fixed the problem (!). There were no errors in the log whatsoever.

This is a very weird bug and I doubt I'll ever see it again, but I'm logging this bug report in case it comes up again.

RJ Ryan (rryan) on 2011-11-05
Changed in mixxx:
importance: Undecided → Critical
milestone: none → 1.10.0
RJ Ryan (rryan) wrote :

Owen, have you been able to reproduce this at all?

Changed in mixxx:
status: New → Confirmed
Owen Williams (ywwg) wrote :

I have never seen this. I tried to think of ways it might have happened and I have no idea. The only way there can be a good vinyl signal but no playback is if CONST mode gets turned on, but by default CONST takes the most recent pitch so it doesn't stop playback like that. The signal overlay being frozen is a clue that something might have happened at the sound-card level. Very weird!

RJ Ryan (rryan) on 2011-12-25
Changed in mixxx:
milestone: 1.10.0 → 1.10.1
Pandemonium (djpandemonium) wrote :

I have experienced this (or something much like it) a handful of times in the couple weeks I've been using Mixxx. I saved a log when it occurred recently. It ends in a bunch of incidents like:
Debug: []: Couldn't get chunk 1240 in read() of [ 20322920 , 20323042 ] chunks 1240 - 1240

I'll attach the log.

My setup includes:
New Macbook Air 13" (OSX 10.7.3)
1.7GHz dual-core Intel Core i5
4GB RAM
Audio 4 DJ
Serato Scratch records
Novation Dicers (simple midi controllers)

Pandemonium (djpandemonium) wrote :

Update: I found that decreasing the sample rate to 44.1khz and increasing the latency slightly resolved this for me. No crashes in 15+ hours of use since the change.

Still, crashing isn't the appropriate behavior for setting overly aggressive sample rates and latency.

RJ Ryan (rryan) on 2012-11-21
Changed in mixxx:
milestone: 1.10.1 → none
Owen Williams (ywwg) wrote :

It's been over a year with no updates, so I'm going to close this bug as Incomplete.

Changed in mixxx:
status: Confirmed → Incomplete
assignee: nobody → Owen Williams (ywwg)
Owen Williams (ywwg) wrote :

(assigning to me to prevent the janitor from cleaning it up)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments