EngineBuffer ramp in and out interval is latency dependent

Bug #884567 reported by RJ Skerry-Ryan on 2011-11-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Owen Williams

Bug Description

Looks like the ramp in and out behavior has changed significantly compared to 1.9.

In 1.9, the ramp out and in was 50 samples, something like 1ms @ 44.1kHz.

In 1.10, the ramp in is 5 callbacks worth of audio. The ramp-out is 12.5 callbacks of audio. At 20ms latency, this is a 100ms ramp in and a 250ms ramp out. It's pretty noticeable when you are previewing a hotcue, for example.

Ramp/in out should not depend on latency or the song samplerate (so both 1.9 and 1.10 are not ideal) -- it should be a desired time interval ramp-in like 1ms or 5ms. I think 1ms is enough to accomplish the task of ramp-in which is to smooth discontinuity caused by abrupt starts and stops.

RJ Skerry-Ryan (rryan) on 2011-11-01
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 1.10.0
Owen Williams (ywwg) wrote :

That was my change. I'll see if I can reduce the length of the ramp without hurting the quality

Changed in mixxx:
assignee: nobody → Owen Williams (ywwg)
Owen Williams (ywwg) wrote :

Here's my fix -- I tested it with my usual stress-test tracks and it sounded fine. It should ramp over 1ms no matter what sample rate. I'll commit if you think it's ok.

Cool -- looks good to me. I'm curious -- what impact does ramping have on
quality for Vinyl Control?

On Tue, Nov 1, 2011 at 9:43 AM, Owen Williams <email address hidden> wrote:

> Here's my fix -- I tested it with my usual stress-test tracks and it
> sounded fine. It should ramp over 1ms no matter what sample rate. I'll
> commit if you think it's ok.
>
> ** Patch added: "simple patch to change ramp durations"
>
> https://bugs.launchpad.net/mixxx/+bug/884567/+attachment/2581650/+files/ramp_1ms.diff
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/884567
>
> Title:
> EngineBuffer ramp in and out interval is latency dependent
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/884567/+subscriptions
>

Owen Williams (ywwg) wrote :

Ramping prevents awful clicks and pops that occur when you're paused in the middle of something with a large waveform like incredible bass. If the platter is drifting ever so slightly, the vinyl control signal/noise threshold will flutter between stopped and started and you get pop-pop-pop-pop as the playhead plays and stops and plays and stops. Ramping smooths all that out. (Check out the youtube video of QBert comparing Serato with Traktor. He bangs on the turntable to make the needle move a tiny bit and notices that serato pops every time he does it (http://www.youtube.com/watch?v=fTj-L7EKCL8))

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers