Selected sidebar item's branch indicator shows wrong color when out of focus.

Bug #880588 reported by RJ Skerry-Ryan on 2011-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
jus
1.10
Low
jus
1.9
Low
jus

Bug Description

While fixing the rating-column wrong-color bug, Tobias and I noticed that the sidebar branch indicator for the selected item is also the wrong color when the window goes out of focus. After debugging a bit, we found that if you remove this block from the skin.xml, it fixes the issue:

<!--Workaround for QT4.7.0 background color bug in Linux with Gnome https://bugs.launchpad.net/mixxx/+bug/690280-->
QTreeView::branch:has-children:!has-siblings:closed,
QTreeView::branch:closed:has-children:has-siblings { border-image: none; image: url(skin:/style/style_branch_closed.png);}
QTreeView::branch:open:has-children:!has-siblings,
QTreeView::branch:open:has-children:has-siblings { border-image: none; image: url(skin:/style/style_branch_open.png);}

This was part of our workaround for Bug #690280 on Linux. I wonder if it is still an issue in Qt 4.7.1 on Linux. If it isn't, then we could just remove these workarounds from the skins and tell people on Linux to upgrade their Qt version.

Related branches

RJ Skerry-Ryan (rryan) wrote :
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → jus (jus)
jus (jus) wrote :

If we completely remove the said part from skin.xml, we loose the custom treeview graphics. Currently we have a triangle for closed/opened branches across all supported OS`s.

Looks like the QTreeView::branch background image declaration is missing/incorrect ( the snippet is from 1.9 skins, it has already slightly changed in 1.10). I`ll have a look into it.

Changed in mixxx:
status: Confirmed → In Progress
jus (jus) on 2011-10-29
Changed in mixxx:
status: In Progress → Fix Committed
jus (jus) wrote :

Fixed for v1.10+ skins in http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/trunk/revision/2924
Tested ok with MacOSX 10.6.8 and Ubuntu Linux 11.10 with Gnome3&KDE4.6

TODO: Fix for v1.9 skins

Hey Jus,

I'm now getting merge conflicts from 1.9 to trunk because of the skin fixes
in 1.9 vs. the skin fixes in trunk. Should I tell bzr to ignore the changes
you made to fix this in 1.9 since you have already applied them in trunk?
Or are there some changes that should be merged from 1.9 into trunk?

On Sun, Oct 30, 2011 at 3:55 AM, jus <email address hidden> wrote:

> ** Changed in: mixxx/1.9
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/880588
>
> Title:
> Selected sidebar item's branch indicator shows wrong color when out of
> focus.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/880588/+subscriptions
>

jus (jus) wrote :

The skin changes from 1.9 should NOT go into trunk. The skins code has diverged much.
Thats why i pushed separate changes for trunk/1.10 and 1.9.

Just ignore the skin related changes when merging from 1.9.

RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers