cannot drag multiple files to a crate

Bug #879439 reported by ewan colsell on 2011-10-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan
1.10
Medium
RJ Skerry-Ryan
1.9
Medium
Unassigned

Bug Description

if i select multiple files using SHIFT <Down Arrow>, and try to drag them to a crate, nothing happens

RJ Skerry-Ryan (rryan) wrote :

Hi ewan,

- What version of Mixxx are you using?
- Are you dragging tracks from outside of mixxx or from inside?

I cannot currently reproduce using our latest trunk.

Changed in mixxx:
importance: Undecided → Medium

Sorry for the sloppy bug reporting.

1.10 Beta on win xp.
dragging from the browse view to the crate

2011/10/23, RJ Ryan <email address hidden>:
> Hi ewan,
>
> - What version of Mixxx are you using?
> - Are you dragging tracks from outside of mixxx or from inside?
>
> I cannot currently reproduce using our latest trunk.
>
> ** Changed in: mixxx
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/879439
>
> Title:
> cannot drag multiple files to a crate
>
> Status in Mixxx:
> New
>
> Bug description:
> if i select multiple files using SHIFT <Down Arrow>, and try to drag
> them to a crate, nothing happens
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/879439/+subscriptions
>

--
Inviato dal mio dispositivo mobile

http://www.ewancolsell.com/

RJ Skerry-Ryan (rryan) wrote :

I can't seem to reproduce using the browse mode on current 1.10.0 beta packages. (The beta packages are still changing since they are not released yet)

It's possible this only affects Windows or the bug has been fixed. Sean or any other windows tester, could you please try adding multiple WAV files from the browse feature on 1.10 to a crate. Just to be sure, use a fresh library.

RJ Skerry-Ryan (rryan) wrote :

Works for me on Linux. Sean will hopefully test this with a recent 1.10 binary to verify it's fixed.

i just tried to reproduce again.
trying agian on a diferent install and i can't reproduce it. still xp
and 1.10 beta1, but on a desktop rather than a netbook.

ewan.

On 29 October 2011 07:06, RJ Ryan <email address hidden> wrote:
> Works for me on Linux. Sean will hopefully test this with a recent 1.10
> binary to verify it's fixed.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/879439
>
> Title:
>  cannot drag multiple files to a crate
>
> Status in Mixxx:
>  New
> Status in Mixxx 1.10 series:
>  New
> Status in Mixxx 1.9 series:
>  New
>
> Bug description:
>  if i select multiple files using SHIFT <Down Arrow>, and try to drag
>  them to a crate, nothing happens
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/879439/+subscriptions
>

--
http://www.ewancolsell.com/

I just tested on Windows XP with x86 and x64 builds of today's 1.10 beta1 RC and I can't drag anything from the library to anything else (Crate, Playlist, Auto DJ), regardless of file type. Right-clicking works fine though. 1.9.2 RC allows dragging just fine as well.

BTW, I get the invalid drop zone mouse cursor

jus (jus) wrote :

Same here, cant drag tracks from the library to anything else , no matter if single or multiple tracks are selected.
Win 7 x86 & today's 1.10 beta1 RC

RJ Skerry-Ryan (rryan) wrote :

Eh.. I can't really reproduce but I fixed something that I think might have caused the problem. Can you guys please test?

1.10 r2869 shows no improvement.

RJ Skerry-Ryan (rryan) wrote :

The fixes didn't end up in 1.10 until r2873. Test again please?

On Tue, Nov 1, 2011 at 3:01 AM, Sean M. Pappalardo <
<email address hidden>> wrote:

> 1.10 r2869 shows no improvement.
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/879439
>
> Title:
> cannot drag multiple files to a crate
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/879439/+subscriptions
>

Tests good in 1.10 r2890 on Windows XP x64.

RJ Skerry-Ryan (rryan) on 2011-11-02
Changed in mixxx:
status: New → Fix Committed
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers