Played checkbox widgets in library view take 2 clicks to check.

Bug #878587 reported by RJ Skerry-Ryan on 2011-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Unassigned
1.10
Low
Unassigned
1.9
Low
Unassigned

Bug Description

You have to click them twice to go from unchecked -> checked.

RJ Skerry-Ryan (rryan) on 2011-10-20
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
RJ Skerry-Ryan (rryan) wrote :

This seems magically fixed...

jus (jus) wrote :

Perhaps it is because with fixing lp:684781 in lp:mixxx r2919 there are no custom checkbox graphics anymore?

RJ Skerry-Ryan (rryan) wrote :

Yes could be related.

RJ Skerry-Ryan (rryan) wrote :

But I think I saw that it was fixed before this weekend.

Owen Williams (ywwg) wrote :

It looks like it's mostly fixed, but I notice if my finger is moving on my touchpad at all, mixxx seems to start to initiate a drag event immediately. (the mouse icon changes to indicate an invalid drop zone.) So it looks like QT is being overly sensitive to mouse motion events and starting a drag instead of triggering the checkbox.

RJ Skerry-Ryan (rryan) wrote :

Jus, I just fixed that bug (the rating checkboxes reverting to their native widgets) and the checkbox still checks with only one click for me.

RJ Skerry-Ryan (rryan) wrote :

Not sure what we can do about the trackpad dragging, Owen. The original problem (which I remember being very noticable) seems fixed to me. Re-open if you reproduce it.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers