Loops can be placed in the lead-in part of a track, which locks the player

Bug #864590 reported by jus on 2011-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Critical
RJ Skerry-Ryan

Bug Description

Tested with latest lp:mixxx/1.10 r 2846 on MacOS 10.6.8

Steps to reproduce:
1. Load a track and scroll into the lead-in part of the track ( so that the elapsed time is negative)
2 Place a beatloop ( e.g. hit the "2" loop button)
2. Hit "Play" Button

Actual behavior:
Playposition jumps too the tracks beginning if passed by the loops end marker.
Track dont play back as long the loop is active even if the "Play" button is in its active state and you can`t scroll the waveform any more.

Expected behavior:
Loops should not be placed in the lead-in part of a track

RJ Skerry-Ryan (rryan) on 2011-10-02
Changed in mixxx:
status: New → Confirmed
importance: Undecided → High
milestone: none → 1.10.0
RJ Skerry-Ryan (rryan) wrote :

Critical because it can ruin a performance (as per new importance guidelines http://mixxx.org/wiki/doku.php/launchpad_bugs )

Changed in mixxx:
importance: High → Critical
RJ Skerry-Ryan (rryan) wrote :

I've updated this to allow loops in the lead-in.

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2011-10-14
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers