Build errors on Gentoo linux

Reported by xorik on 2011-09-12
This bug report is a duplicate of:  Bug #798790: linux kernel 3. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Unassigned

Bug Description

When I try to build mixxx on gentoo, configure causing the errors:
# scons | grep ERROR
ERROR:root:Unmet dependency: Did not find libmad.a, libmad.lib, or the libmad development header files - exiting!
ERROR:root:Unmet dependency: Did not find libsndfile or it's development headers, exiting!
ERROR:root:Unmet dependency: Did not find libFLAC development libraries, exiting!
ERROR:root:Unmet dependency: Did not find libvorbis.a, libvorbis.lib, or the libvorbisfile development headers.
ERROR:root:Unmet dependency: Did not find GLU development files, exiting!
ERROR:root:Unmet dependency: Could not find libtag or its development headers.
ERROR:root:Unmet dependency: Could not find libmp4, libmp4v2 or the libmp4v2 development headers.
ERROR:root:Build had unmet dependencies. Exiting.

but I have install all of these libraries with their developer files. For example:
$ pkg-config --libs mad
-lmad -lm

$ locate mad.h
/usr/include/mad.h

xorik (xor29a) wrote :

You can get complete build log and config.log here: https://bugs.gentoo.org/show_bug.cgi?id=310821#c77

xorik (xor29a) wrote :

thank you! with patch problem solved

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.