Library view is escaping its frame in Outline800x480-WVGA

Bug #804529 reported by Daniel Schürmann on 2011-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

The bug is caused by the dlgprepare.ui, Its menu bar is to big.
I have changed "* Recently Added * All Songs" to "* New * All" to solve the bug.

I have tested it on Ubuntu Natty with the current trunk 2837.

Related branches

jus (jus) on 2011-07-02
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

It took me very long to figure out what happens, but finally, here is the patch!

Changed in mixxx:
status: In Progress → Fix Committed

Hey Daniel,

Does expanding / collapsing widget groups like the sampler groups still work
with this change? I think setting the max and min sizes equal will prevent
the library widget from auto-resizing when the sampler widget group is
expanded.

cheers,
RJ Ryan

2011/7/6 Daniel Schürmann <email address hidden>

> It took me very long to figure out what happens, but finally, here is
> the patch!
>
> ** Attachment added: "legacyskinparser_patch"
>
> https://bugs.launchpad.net/mixxx/+bug/804529/+attachment/2194498/+files/legacyskinparser_patch
>
> ** Changed in: mixxx
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/804529
>
> Title:
> Library view is escaping its frame in Outline800x480-WVGA
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/804529/+subscriptions
>

Changed in mixxx:
status: Fix Committed → In Progress
Daniel Schürmann (daschuer) wrote :

Hi RJ Ryan

you are right, in the Deere1280x800-EXPERIMENTAL Skin the library is not shown at all.

The original bug is caused by the fixed size hint of QTreeView = 256.

The pSplitter resizes to size of the pLibrarySideBarPage->sizeHint() + pLibraryPage->sizeHint().
And if this sum is greater than the pTabWidget, the escaping is shown.

I have tried to override sizeHint() of pLibrarySideBar to return a width of 100.
Unfortunately the Layout did not use the sizeHint() function.

A solution could be to set the size hint from the Library tree view to its minimum Size of 84.

Do you know how?

Daniel Schürmann (daschuer) wrote :

Now the Library is back in the Deere1280x800-EXPERIMENTAL skin. Expanding the sampler widget works as well.

Changed in mixxx:
status: In Progress → Fix Committed

Please don't set bugs Fix Committed until they've actually been fixed in the code branch. (Once your patch has actually been committed to trunk, we'll set this status.

Changed in mixxx:
status: Fix Committed → In Progress
Daniel Schürmann (daschuer) wrote :

Attached you will find an updated version of the patch, created with lp:mixxx #2930.

I would like to see this patch in mixxx 1.10. Just switch to Outline800x480-WVGA and you will see what I mean.

RJ Skerry-Ryan (rryan) on 2011-10-31
Changed in mixxx:
milestone: none → 1.10.0
RJ Skerry-Ryan (rryan) wrote :

Sounds good to me -- in general I like to avoid messing with Qt layouts and giving them explicit limits because it sometimes causes problems with dynamic layouts (e.g. library expanding / contracting) but since it's the width it should be fine. I'll put the patch in 1.10 beta and see if we hear of any problems with it.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers