Track analysis progress visualisation

Reported by Jonas Ådahl on 2011-06-30
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Jonas Ådahl

Bug Description

When loading a track to a deck, one thing I missed from a UI feedback
perspective was knowing how the analysis went and how long I had to
wait. I missed it enough so that I downloaded the source code for
mixxx (the default branch "trunk") and started to hack on adding a
progress bar.

Result is available as the attached patch. I also attached a
screenshot illustrating the results. The darker orange background of
the right wave form overview widget will be filled completely when the
track has been analyzed, like a progress bar. The color used is the
same as the wave form color, but with alpha value 80 out of 255.

Related branches

Jonas Ådahl (jadahl) wrote :
Jonas Ådahl (jadahl) wrote :

Added screenshot.

jus (jus) on 2011-07-02
Changed in mixxx:
importance: Undecided → Wishlist
status: New → Confirmed
Jonas Ådahl (jadahl) on 2011-07-10
Changed in mixxx:
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Hi Jonas,

I have tested your patch on my netbook with ubuntu lucid and it works like a charm.

Especially on a slow Atom CPU it is very useful.

I have committed it to lp:~daschuer/mixxx/daschuers_trunk.

Btw.: Compiling produces warnings, but not caused by this patch.

jus (jus) wrote :

Like that feature very much, nice touch.

Changed in mixxx:
milestone: none → 1.10.1
assignee: nobody → Jonas Ådahl (jadahl)
RJ Ryan (rryan) on 2011-11-23
Changed in mixxx:
milestone: 1.10.1 → 1.10.0
RJ Ryan (rryan) on 2011-11-26
Changed in mixxx:
status: In Progress → Fix Committed
RJ Ryan (rryan) wrote :

Thanks so much Jonas -- added to the 1.10 branch. Since it's a huge usability win and the code was very straightforward I don't feel any qualms about including in 1.10.0.

I have made the progress color and alpha value skinnable. To skin the value, simply put

<Overview>
...
<ProgressColor>#ffffff</ProgressColor>
<ProgressAlpha>80</ProgressAlpha>
...
</Overview>

The progress color defaults to the signal color and the default alpha is 80 out of 255.

Jonas, how would you like your name credited on the contributor list? Is "Jonas Ådahl" ok?

Also, could you please fill out the contributor agreement to get a record that you are giving us permission to use your code:

https://docs.google.com/a/mixxx.org/spreadsheet/viewform?hl=en_US&pli=1&formkey=dEpYN2NkVEFnWWQzbkFfM0ZYYUZ5X2c6MQ#gid=0

Jonas Ådahl (jadahl) wrote :

Skinnable, cool :)

"Jonas Ådahl" sounds good, thank you. Agreement signed.

Can this be extended to apply to the Samplers as well?

RJ Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments