Cannot drag Itunes playlist to AutoDJ

Bug #798541 reported by Tony Mason on 2011-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Daniel Schürmann

Bug Description

if you make a Playlist in Itunes and load it into MIXXX 1.9.0, you cannot in the Itunes Playlist view,
1) right click and load to Auto DJ, you can only load to Deck 1&2.
2) You cannot drag the I tunes Playlist to Auto DJ.
3) You can only view the playlist use Shift Click to select all the tracks and drag them to Auto DJ

It would be very nice to right click on the Playlist in the 'tree' view and select add to AutoDJ

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: New → Confirmed
Changed in mixxx:
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

The attached patch adds context menus to the Rhythmbox and ITunes playlists with:
* "Add to Auto DJ bottom"
* "Add to Auto DJ top 2"
* "Import as Mixxx Playlist"

The patch includes also the patch from Bug #834006

Daniel Schürmann (daschuer) wrote :

The Rhythmbox part was tested with lp:mixxx #2840 and ubuntu natty.

RJ Skerry-Ryan (rryan) on 2011-10-05
Changed in mixxx:
importance: Undecided → Wishlist
RJ Skerry-Ryan (rryan) on 2011-10-05
tags: added: library
RJ Skerry-Ryan (rryan) on 2011-10-05
tags: added: autodj
Daniel Schürmann (daschuer) wrote :

Updated the patch for lp:mixxx #2876

RJ Skerry-Ryan (rryan) on 2012-05-02
Changed in mixxx:
milestone: none → 1.11.0
RJ Skerry-Ryan (rryan) wrote :

Wow this patch rotted quite a lot because parts of this patch made it into the codebase via other patches. I fixed it all up and committed it (well, I reworked it so that ITunesFeature, RhythmboxFeature, and TraktorFeature all inherit a base class that contains the logic to avoid duplication).

thanks!

RJ Skerry-Ryan (rryan) on 2012-05-11
Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers