played counter counting loads, not playes

Bug #783634 reported by Daniel Schürmann on 2011-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

The played counter is incremented when a track is loaded to the deck. It should be incremented when the track is played to to master output. Today we have a distortion in played counter if we load tracks for headphones preview.
(trunk version)

Related branches

jus (jus) on 2011-07-02
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Bug is solved in lp:~daschuer/mixxx/daschuers_trunk by the setlog (history) feature.

I just wanted to point out that there is already some good logic for determining when a song is playing that Phillip Whelan (Madjester) wrote for the shoutcast metadata feature. This code is in the 1.9 branch and onward. I haven't looked at your code yet, but if you haven't made use of this logic, please do, so we can have a single object used across Mixxx that determines if and what deck is playing.

RJ Skerry-Ryan (rryan) on 2011-09-30
tags: added: library
Daniel Schürmann (daschuer) wrote :

I do use the PlayerInfo Class introduced by Phillip Whelan.

In my current solution, the setlogfeature is connected to the valueChanged Signal of "playposition" to calculate the current playing track using the PlayerInfo Class.

Eniginerecord and shoutcast are also continuously calculating what audience is listening.

It looks like a good idea, to let only one class calculate this and emit a signal when the current playing track is changed. I am not sure what is the right thread for this work and what is the outcome for enginerecord and shoutcast. For now, I am satisfied with the current solution.

Changed in mixxx:
status: In Progress → Fix Committed
milestone: none → 1.11.0
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers