Some shortcuts defined in Standard.kbd.cfg missing in tooltips

Bug #696058 reported by hiend on 2010-12-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann
1.10
Low
Daniel Schürmann

Bug Description

Missing shortcut for channel 2 Tap button in "Late Night" skin.

jus (jus) wrote :

Shortcuts are not skin specific.
They are defined application wide http://mixxx.org/wiki/doku.php/manual?#keyboard_shortcuts
Default shortcut for BPM tap Channel1 = Q / Channel 2=U

What you see might be the following:
The existing and working shortcut for channel 2 is not shown on the skins`s tooltips, no matter what skin.
Interestingly if you change the shortcuts for Channel 1 and 2 in Standard.kbd.cfg and re-launch Mixxx, the shortcut for Channel 1 in missing while its shown for Channel 2 now.

So in summary, it may be an error with the underlaying code and not with the skins

jus (jus) wrote :

This still happens with trunk.
Some shortcuts simply do not appear in the tooltips, but i can`t see a pattern .

summary: - Mixxx 1.9.0 missing shortcut
+ Some shortcuts defined in Standard.kbd.cfg missing in tooltips
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
Daniel Schürmann (daschuer) wrote :

the attached patch against lp:mixxx #2969.
It introduces the shortcut translation as well.

Changed in mixxx:
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Ops, I have just noticed that I have used a Qt 4.7 function.

Daniel Schürmann (daschuer) wrote :
jus (jus) wrote :

Thanks for the patch.
It worked pretty well with latest lp:mixxx/1.10 on MacOSX 10.6.8.

Interestingly some of the shortcuts available in Standard.kbd.cfg are still not displayed in the tooltips (at least on MacOS). I tried to re-assign the shortcuts with no result.

Keys with display issues:
crossfader_up
crossfader_down
crossfader_up_small
crossfader_down_small

beatloop_4_toggle ( you can substitute the 4 with any of the available numbers from 0.0625-64 with no result)

Personally i like that the key sequence is translated in a platform specific string.
It might be confusing to users on Windows cause QKeySequence::NativeText returns "Meta" key instead of "Windows" key . Can´t test on Windows if QT bug is still present: https://bugreports.qt-project.org/browse/QTBUG-4181?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel#issue-tabs

Daniel Schürmann (daschuer) wrote :

Hi jus,

the attached patch solves the problem.

Cheers, Daniel

Daniel Schürmann (daschuer) wrote :
jus (jus) wrote :

Thanks, now the shortcuts are perfectly displayed on all controls.

There are now suffixes added to some of the shortcuts - not sure if we should keep them or leave it simply to the tooltips explanatory text. Some of the suffixes are misleading like "up/up_small" and "down/down_small" when a fader moves horizontally.

Changed in mixxx:
milestone: none → 1.10.1
RJ Skerry-Ryan (rryan) wrote :

Since you are already casting to WSliderComposed, you could just add a method isHorizontal() to WSliderComposed and if horizontal, use left/right instead of up/down. Otherwise the patch looks good to me and feel free to commit it.

thanks,
RJ

Changed in mixxx:
milestone: 1.10.1 → 1.11.0
status: In Progress → Fix Committed
no longer affects: mixxx/1.11
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers