Move tooltips out of skin.xml into source code

Bug #691864 reported by jus on 2010-12-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
RJ Skerry-Ryan

Bug Description

Tooltips should move out of the skins.xml into the source for various reasons
- to support ongoing mixxx-i18n efforts
- to provide a coherent user experience for all skins
- to eliminate a source of error for skin designers

Current tooltips are maybe a little to extensive so the content could use an overhaul too.

Also we should find a way to differentiate between "regular" tooltips and library tooltips as suggested here: https://bugs.launchpad.net/mixxx/+bug/662540

Related branches

RJ Skerry-Ryan (rryan) on 2011-03-20
Changed in mixxx:
status: New → Confirmed
tags: added: i18n
RJ Skerry-Ryan (rryan) wrote :

I agree that the tooltips shouldn't be in the skin.xml. Were you thinking we would automatically figure out the tooltip to display based on the connections? We could also switch to an ID system that works like this:

Deprecate the <Tooltip> section. Allow widget tags to take a tooltip="" attribute.

<Visual tooltip="waveform-display">

</Visual>

In the code, there will be a tooltips file that maps the tooltip IDs to their text. This way, we can submit the tooltip text for translations. If a skin designer would like to provide a custom tooltip or override a Mixxx default one, they can make a tooltips.xml to stick in their skin folder. It could look like this:

<tooltips>
<tooltip id="waveform-display" language="en">Custom text for waveform tooltip</tooltip>
<tooltip id="waveform-display" language="fr">...</tooltip>
</tooltips>

This should be discouraged since the skin designer will have to provide translations for their tooltips, but it will still allow them to make custom tooltips, while using the Mixxx provided ones by default. What do you think?

Changed in mixxx:
importance: Undecided → Wishlist
jus (jus) wrote :

Nah, no custom tooltips anymore but allow styling.
Have the standard ones translated and displayed with the associated shortcuts and thats it.

Tooltip attribute sounds good.
Naming convention should be in line with <ConfigKey> http://mixxx.org/wiki/doku.php/midi_controller_mapping_file_format#ui_midi_controls_and_names
This way we use these Key/Control names for Midi,Keyboard and Skins.

Some things to think on:
* That <Visual> and <Text> are some kind of exceptions
* That a button can have more than 1 <NumberStates>
* To display tooltips for the <Property> field inside a <TrackProperty> node

If the tooltips get some polish, we should separate them from the library tooltips
https://bugs.launchpad.net/mixxx/+bug/662540

It should be also possible to de/activate them from within the UI.

RJ Skerry-Ryan (rryan) on 2011-03-20
tags: added: tooltips
RJ Skerry-Ryan (rryan) on 2011-11-28
Changed in mixxx:
milestone: none → 1.11.0
RJ Skerry-Ryan (rryan) on 2012-05-07
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)

Skins now support a <TooltipId> tag in place of a <Tooltip> tag. If you
provide an ID of a tooltip we have hardcoded in Mixxx then the tooltip will
be the translated, hard-coded version. I didn't go with attributes since
generally we don't use attributes much in the skin.xml so I figured I'd
keep with the style.

I didn't do anything fancy with left-click or right-click tooltips. I just
verbatim copied each one and gave each unique tooltip in our current set of
skin.xml tooltips into its own tooltip id.

On Mon, May 7, 2012 at 2:20 PM, RJ Ryan <email address hidden> wrote:

> ** Changed in: mixxx
> Assignee: (unassigned) => RJ Ryan (rryan)
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/691864
>
> Title:
> Move tooltips out of skin.xml into source code
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/691864/+subscriptions
>

jus (jus) on 2012-05-08
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers